aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx/image
diff options
context:
space:
mode:
authorCsaba Sipos <metro4@freemail.hu>2022-10-03 19:13:22 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2022-10-30 23:14:45 +0100
commitcc8b8f1b41ad2dadff4c95b8629c249b04846168 (patch)
treec66e27d91009a9787177861259a81387568b407c /target/linux/ipq40xx/image
parent80edacc8a697b5aaacf3a26d462c1fd9e1d5a639 (diff)
downloadupstream-cc8b8f1b41ad2dadff4c95b8629c249b04846168.tar.gz
upstream-cc8b8f1b41ad2dadff4c95b8629c249b04846168.tar.bz2
upstream-cc8b8f1b41ad2dadff4c95b8629c249b04846168.zip
ipq40xx: add support for MikroTik hAP ac3 LTE6 kit
This adds support for the MikroTik RouterBOARD RBD53GR-5HacD2HnD (hAP ac³ LTE6 kit), an indoor dual band, dual-radio 802.11ac wireless AP with built-in Mini PCI-E LTE modem, one USB port, five 10/100/1000 Mbps Ethernet ports. See https://mikrotik.com/product/hap_ac3_lte6_kit for more info. Specifications: - SoC: Qualcomm Atheros IPQ4019 - RAM: 256 MB - Storage: 16 MB NOR - Wireless: · Built-in IPQ4019 (SoC) 802.11b/g/n 2x2:2, 3 dBi internal antennae · Built-in IPQ4019 (SoC) 802.11a/n/ac 2x2:2, 5.5 dBi internal antennae - Ethernet: Built-in IPQ4019 (SoC, QCA8075) , 5x 1000/100/10 port - 1x USB Type A port - 1x Mini PCI-E port (supporting USB) - 1x Mini PCI-E LTE modem (MikroTik R11e-LTE6, Cat.6) Installation: Make sure your unit is runnning RouterOS v6 and RouterBOOT v6 (tested on 6.49.6). 0. Export your MikroTik license key (in case you want to use the device with RouterOS later) 1. Boot the initramfs image via TFTP 2. Upload the "openwrt-ipq40xx-mikrotik-mikrotik_hap-ac3-lte6-kit-squashfs-sysupgrade.bin" via SCP to the /tmp folder 3. Use sysupgrade to flash the image: sysupgrade -n /tmp/openwrt-ipq40xx-mikrotik-mikrotik_hap-ac3-lte6-kit-squashfs-sysupgrade.bin 4. Recovery to factory software is possible via Netinstall: https://help.mikrotik.com/docs/display/ROS/Netinstall Signed-off-by: Csaba Sipos <metro4@freemail.hu>
Diffstat (limited to 'target/linux/ipq40xx/image')
-rw-r--r--target/linux/ipq40xx/image/mikrotik.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ipq40xx/image/mikrotik.mk b/target/linux/ipq40xx/image/mikrotik.mk
index d1f0829cd3..2b0e462efd 100644
--- a/target/linux/ipq40xx/image/mikrotik.mk
+++ b/target/linux/ipq40xx/image/mikrotik.mk
@@ -47,6 +47,14 @@ define Device/mikrotik_hap-ac3
endef
TARGET_DEVICES += mikrotik_hap-ac3
+define Device/mikrotik_hap-ac3-lte6-kit
+ $(call Device/mikrotik_nor)
+ DEVICE_MODEL := hAP ac3 LTE6 kit
+ SOC := qcom-ipq4019
+ DEVICE_PACKAGES := kmod-ledtrig-gpio kmod-usb-acm kmod-usb-net-rndis
+endef
+TARGET_DEVICES += mikrotik_hap-ac3-lte6-kit
+
define Device/mikrotik_lhgg-60ad
$(call Device/mikrotik_nor)
DEVICE_MODEL := Wireless Wire Dish LHGG-60ad