aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx/image
diff options
context:
space:
mode:
authorWeiping Yang <weiping.yang@gl-inet.com>2022-09-19 05:47:40 -0400
committerHauke Mehrtens <hauke@hauke-m.de>2022-11-09 23:34:37 +0100
commit9945d05171dd5f71c1d288ed63fa4112024d0a85 (patch)
tree97315b581b77b69700e4909e6fc301860a823212 /target/linux/ipq40xx/image
parent79107116d115c4d96c5cd0446c11b3751e597fce (diff)
downloadupstream-9945d05171dd5f71c1d288ed63fa4112024d0a85.tar.gz
upstream-9945d05171dd5f71c1d288ed63fa4112024d0a85.tar.bz2
upstream-9945d05171dd5f71c1d288ed63fa4112024d0a85.zip
ipq40xx: add support for GL.iNet GL-A1300
Specifications: SOC: Qualcomm IPQ4018 (DAKOTA) ARM Quad-Core RAM: 256 MiB FLASH1: 4 MiB NOR FLASH2: 128 MiB NAND ETH: Qualcomm QCA8075 WLAN1: Qualcomm Atheros QCA4018 2.4GHz 802.11b/g/n 2x2 WLAN2: Qualcomm Atheros QCA4018 5G 802.11n/ac W2 2x2 USB: 1 x USB 3.0 port Button: 1 x Reset button Switch: 1 x Mode switch LED: 1 x Blue LED + 1 x White LED Install via uboot tftp or uboot web failsafe. By uboot tftp: (IPQ40xx) # tftpboot 0x84000000 openwrt-ipq40xx-generic-glinet_gl-a1300-squashfs-nand-factory.ubi (IPQ40xx) # nand erase 0 0x8000000 (IPQ40xx) # nand write 0x84000000 0 $filesize By uboot web failsafe: Push the reset button for 10 seconds util the power led flash faster, then use broswer to access http://192.168.1.1 Afterwards upgrade can use sysupgrade image. Signed-off-by: Weiping Yang <weiping.yang@gl-inet.com>
Diffstat (limited to 'target/linux/ipq40xx/image')
-rw-r--r--target/linux/ipq40xx/image/generic.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/ipq40xx/image/generic.mk b/target/linux/ipq40xx/image/generic.mk
index e8e6e29e72..b50d072bec 100644
--- a/target/linux/ipq40xx/image/generic.mk
+++ b/target/linux/ipq40xx/image/generic.mk
@@ -565,6 +565,20 @@ endef
# Missing DSA Setup
#TARGET_DEVICES += ezviz_cs-w3-wd1200g-eup
+define Device/glinet_gl-a1300
+ $(call Device/FitImage)
+ $(call Device/UbiFit)
+ DEVICE_VENDOR := GL.iNet
+ DEVICE_MODEL := GL-A1300
+ SOC := qcom-ipq4018
+ DEVICE_DTS_CONFIG := config@ap.dk01.1-c2
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ IMAGE_SIZE := 131072k
+ DEVICE_PACKAGE := ipq-wifi-glinet_gl-a1300
+endef
+TARGET_DEVICES += glinet_gl-a1300
+
define Device/glinet_gl-ap1300
$(call Device/FitImage)
$(call Device/UbiFit)