aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx/image
diff options
context:
space:
mode:
authorRobert Marko <robimarko@gmail.com>2020-11-12 19:45:22 +0100
committerAlexander Couzens <lynxis@fe80.eu>2021-04-05 04:13:28 +0200
commitfaea7becafc634dc882f0ad8f9388862ccd5bd0d (patch)
treee80f87fb71b05f31889dd6852dba7e82356314d5 /target/linux/ipq40xx/image
parent1db4681617b9aef724c9ccf15e62ba2a91d52564 (diff)
downloadupstream-faea7becafc634dc882f0ad8f9388862ccd5bd0d.tar.gz
upstream-faea7becafc634dc882f0ad8f9388862ccd5bd0d.tar.bz2
upstream-faea7becafc634dc882f0ad8f9388862ccd5bd0d.zip
ipq40xx: add MikroTik hAP ac2 support
This adds support for the MikroTik RouterBOARD RBD52G-5HacD2HnD-TC (hAP ac²), a indoor dual band, dual-radio 802.11ac wireless AP with integrated omnidirectional antennae, USB port and five 10/100/1000 Mbps Ethernet ports. See https://mikrotik.com/product/hap_ac2 for more info. Specifications: - SoC: Qualcomm Atheros IPQ4018 - RAM: 128 MB - Storage: 16 MB NOR - Wireless: · Built-in IPQ4018 (SoC) 802.11b/g/n 2x2:2, 2.5 dBi antennae · Built-in IPQ4018 (SoC) 802.11a/n/ac 2x2:2, 2.5 dBi antennae - Ethernet: Built-in IPQ4018 (SoC, QCA8075) , 5x 1000/100/10 port, passive PoE in - 1x USB Type A port Installation: Boot the initramfs image via TFTP and then flash the sysupgrade image using "sysupgrade -n" Signed-off-by: Robert Marko <robimarko@gmail.com>
Diffstat (limited to 'target/linux/ipq40xx/image')
-rw-r--r--target/linux/ipq40xx/image/mikrotik.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/ipq40xx/image/mikrotik.mk b/target/linux/ipq40xx/image/mikrotik.mk
index e69de29bb2..9509ef8577 100644
--- a/target/linux/ipq40xx/image/mikrotik.mk
+++ b/target/linux/ipq40xx/image/mikrotik.mk
@@ -0,0 +1,20 @@
+define Device/mikrotik_nor
+ DEVICE_VENDOR := MikroTik
+ BLOCKSIZE := 64k
+ IMAGE_SIZE := 16128k
+ KERNEL_NAME := vmlinux
+ KERNEL := kernel-bin | append-dtb-elf
+ IMAGES = sysupgrade.bin
+ IMAGE/sysupgrade.bin := append-kernel | kernel2minor -s 1024 | \
+ pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | \
+ append-metadata | check-size
+endef
+
+define Device/mikrotik_hap-ac2
+ $(call Device/mikrotik_nor)
+ DEVICE_MODEL := hAP ac2
+ SOC := qcom-ipq4018
+ DEVICE_PACKAGES := ipq-wifi-mikrotik_hap-ac2 -kmod-ath10k-ct \
+ kmod-ath10k-ct-smallbuffers
+endef
+TARGET_DEVICES += mikrotik_hap-ac2