aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx/image
diff options
context:
space:
mode:
authorMarek Lindner <marek.lindner@kaiwoo.ai>2018-11-25 21:46:54 +0800
committerPetr Štetiar <ynezz@true.cz>2020-12-22 19:11:50 +0100
commitea5bb6bbfee06f44f714aff40c8929505face221 (patch)
treec3ae619246530a997fffbc38ffde4a2e80b357e7 /target/linux/ipq40xx/image
parent8a891bfaa01d9592ea86c6b0cbbd5c04688c09f8 (diff)
downloadupstream-ea5bb6bbfee06f44f714aff40c8929505face221.tar.gz
upstream-ea5bb6bbfee06f44f714aff40c8929505face221.tar.bz2
upstream-ea5bb6bbfee06f44f714aff40c8929505face221.zip
ipq40xx: add support for Plasma Cloud PA1200
Device specifications: * QCA IPQ4018 * 256 MB of RAM * 32 MB of SPI NOR flash (w25q256) - 2x 15 MB available; but one of the 15 MB regions is the recovery image * 2T2R 2.4 GHz - QCA4019 hw1.0 (SoC) - requires special BDF in QCA4019/hw1.0/board-2.bin with bus=ahb,bmi-chip-id=0,bmi-board-id=16,variant=PlasmaCloud-PA1200 * 2T2R 5 GHz - QCA4019 hw1.0 (SoC) - requires special BDF in QCA4019/hw1.0/board-2.bin with bus=ahb,bmi-chip-id=0,bmi-board-id=17,variant=PlasmaCloud-PA1200 * 3x GPIO-LEDs for status (cyan, purple, yellow) * 1x GPIO-button (reset) * 1x USB (xHCI) * TTL pins are on board (arrow points to VCC, then follows: GND, TX, RX) * 2x gigabit ethernet - phy@mdio4: + Label: Ethernet 1 + gmac0 (ethaddr) in original firmware + used as LAN interface - phy@mdio3: + Label: Ethernet 2 + gmac1 (eth1addr) in original firmware + 802.3af/at POE(+) + used as WAN interface * 12V/24V 1A DC Flashing instructions: The tool ap51-flash (https://github.com/ap51-flash/ap51-flash) should be used to transfer the factory image to the u-boot when the device boots up. Signed-off-by: Marek Lindner <marek.lindner@kaiwoo.ai> [sven@narfation.org: prepare commit message, rebase, use all LEDs, switch to dualboot_datachk upgrade script, use eth1 as designated WAN interface] Signed-off-by: Sven Eckelmann <sven@narfation.org>
Diffstat (limited to 'target/linux/ipq40xx/image')
-rw-r--r--target/linux/ipq40xx/image/Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/ipq40xx/image/Makefile b/target/linux/ipq40xx/image/Makefile
index b3f2d1f755..b0fde22813 100644
--- a/target/linux/ipq40xx/image/Makefile
+++ b/target/linux/ipq40xx/image/Makefile
@@ -648,6 +648,22 @@ define Device/openmesh_a62
endef
TARGET_DEVICES += openmesh_a62
+define Device/plasmacloud_pa1200
+ $(call Device/FitImageLzma)
+ DEVICE_VENDOR := Plasma Cloud
+ DEVICE_MODEL := PA1200
+ SOC := qcom-ipq4018
+ DEVICE_DTS_CONFIG := config@pc.pa1200
+ BLOCKSIZE := 64k
+ KERNEL = kernel-bin | lzma | fit lzma $$(DTS_DIR)/$$(DEVICE_DTS).dtb | pad-to $$(BLOCKSIZE)
+ IMAGE_SIZE := 15616k
+ IMAGES += factory.bin
+ IMAGE/factory.bin := append-rootfs | pad-rootfs | openmesh-image ce_type=PA1200
+ IMAGE/sysupgrade.bin/squashfs := append-rootfs | pad-rootfs | sysupgrade-tar rootfs=$$$$@ | append-metadata
+ DEVICE_PACKAGES := uboot-envtools ipq-wifi-plasmacloud-pa1200
+endef
+TARGET_DEVICES += plasmacloud_pa1200
+
define Device/qcom_ap-dk01.1-c1
DEVICE_VENDOR := Qualcomm Atheros
DEVICE_MODEL := AP-DK01.1