aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx/image
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2020-09-07 13:08:41 +0200
committerJohn Crispin <john@phrozen.org>2020-09-17 08:43:07 +0200
commit0fbdb51f7643db5fa4423333a68f34c6952dba24 (patch)
tree96fe7a46e272c8900730b539bc2355581e580155 /target/linux/ipq40xx/image
parent4488b260a02e169d6902df44debbe9b3c8e001cc (diff)
downloadupstream-0fbdb51f7643db5fa4423333a68f34c6952dba24.tar.gz
upstream-0fbdb51f7643db5fa4423333a68f34c6952dba24.tar.bz2
upstream-0fbdb51f7643db5fa4423333a68f34c6952dba24.zip
ipq40xx: add Edgecore OAP-100 support
flashing the unit * first update to latest edcore FW as per the PDF instructions * boot the initramfs - tftpboot 0x88000000 openwrt-ipq40xx-generic-edgecore_oap100-initramfs-fit-uImage.itb; bootm * inside the initramfs call the following commiands - ubiattach -p /dev/mtd0 - ubirmvol /dev/ubi0 -n0 - ubirmvol /dev/ubi0 -n1 - ubirmvol /dev/ubi0 -n2 * scp the sysupgrade image to the board and call - sysupgrade -n openwrt-ipq40xx-generic-edgecore_oap100-squashfs-nand-sysupgrade.bin Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'target/linux/ipq40xx/image')
-rw-r--r--target/linux/ipq40xx/image/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/ipq40xx/image/Makefile b/target/linux/ipq40xx/image/Makefile
index 127af99ce5..0f03e1f429 100644
--- a/target/linux/ipq40xx/image/Makefile
+++ b/target/linux/ipq40xx/image/Makefile
@@ -356,6 +356,19 @@ define Device/edgecore_ecw5211
endef
TARGET_DEVICES += edgecore_ecw5211
+define Device/edgecore_oap100
+ $(call Device/FitImage)
+ $(call Device/UbiFit)
+ DEVICE_TITLE := Edgecore OAP100
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ IMAGES := nand-sysupgrade.bin
+ DEVICE_DTS_CONFIG := config@ap.dk07.1-c1
+ DEVICE_DTS := qcom-ipq4019-oap100
+ DEVICE_PACKAGES := ipq-wifi-edgecore_oap100 kmod-usb-acm kmod-usb-net kmod-usb-net-cdc-qmi uqmi
+endef
+TARGET_DEVICES += edgecore_oap100
+
define Device/engenius_eap1300
$(call Device/FitImage)
DEVICE_VENDOR := EnGenius