aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx/image
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2018-02-17 09:07:54 +0100
committerMathias Kresin <dev@kresin.me>2018-03-14 19:04:51 +0100
commit249a9b35e0937150e7557931bcdca8b95a6e274d (patch)
tree9d56926002df9a495dfe13bba22647a187983639 /target/linux/ipq40xx/image
parent9f437b2cf32868fe4fe09c54feaec1ca2a69537b (diff)
downloadupstream-249a9b35e0937150e7557931bcdca8b95a6e274d.tar.gz
upstream-249a9b35e0937150e7557931bcdca8b95a6e274d.tar.bz2
upstream-249a9b35e0937150e7557931bcdca8b95a6e274d.zip
ipq40xx: fix GL.iNet GL-B1300 support
Rename the dts file to match the used SoC type and drop the unnecessary KERNEL_INSTALL from the image build code. Remove the fixed rootfs and kernel partitions and create an image with rootfs appended after kernel. Setup a switch portmap matching the hardware and a default network/switch configuration to make make the second lan port working. Use eth0 as lan to have it consistent accross the target. Use the power LED to indicate the boot status. Sort the SoC entries within the dts by address and use dtc labels whenever possible. Signed-off-by: Mathias Kresin <dev@kresin.me> Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Diffstat (limited to 'target/linux/ipq40xx/image')
-rw-r--r--target/linux/ipq40xx/image/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/target/linux/ipq40xx/image/Makefile b/target/linux/ipq40xx/image/Makefile
index 41f396b839..218a80afa7 100644
--- a/target/linux/ipq40xx/image/Makefile
+++ b/target/linux/ipq40xx/image/Makefile
@@ -44,15 +44,14 @@ endef
TARGET_DEVICES += avm_fritzbox-4040
define Device/glinet_gl-b1300
+ $(call Device/FitImage)
DEVICE_TITLE := GL.iNet GL-B1300
BOARD_NAME := gl-b1300
- DEVICE_DTS := qcom-ipq4019-gl-b1300
- KERNEL_INSTALL := 1
+ DEVICE_DTS := qcom-ipq4029-gl-b1300
KERNEL_SIZE := 4096k
IMAGE_SIZE := 26624k
- $(call Device/FitImage)
IMAGES := sysupgrade.bin
- IMAGE/sysupgrade.bin := append-kernel | pad-to $$$${KERNEL_SIZE} | append-rootfs | pad-rootfs | append-metadata
+ IMAGE/sysupgrade.bin := append-kernel |append-rootfs | pad-rootfs | append-metadata
DEVICE_PACKAGES := ipq-wifi-glinet_gl-b1300
endef
TARGET_DEVICES += glinet_gl-b1300