aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx/image
diff options
context:
space:
mode:
authorPiotr Dymacz <pepe2k@gmail.com>2019-01-29 18:12:51 +0100
committerPiotr Dymacz <pepe2k@gmail.com>2019-02-26 00:16:22 +0100
commitc568c6dc09f0a847097fb9697369114a251f096d (patch)
treed2abd71d3a4d03c0ba3c008798404d0e23ab7df4 /target/linux/ipq40xx/image
parentd3f82d3b8466a3328755a80ac249d447cb2309a2 (diff)
downloadupstream-c568c6dc09f0a847097fb9697369114a251f096d.tar.gz
upstream-c568c6dc09f0a847097fb9697369114a251f096d.tar.bz2
upstream-c568c6dc09f0a847097fb9697369114a251f096d.zip
ipq40xx: add support for ALFA Network AP120C-AC
ALFA Network AP120C-AC is a dual-band ceiling AP, based on Qualcomm IPQ4018 + QCA8075 platform. Specification: - Qualcomm IPQ4018 (717 MHz) - 256 MB of RAM (DDR3) - 16 MB (SPI NOR) + 128 MB (SPI NAND) of flash - 2x Gbps Ethernet, with 802.3af PoE support in one port - 2T2R 2.4/5 GHz (IPQ4018), with ext. FEMs (QFE1952, QFE1922) - 3x U.FL connectors - 1x 1.8 dBi (Bluetooth) and 2x 3/5 dBi dual-band (Wi-Fi) antennas - Atmel/Microchip AT97SC3205T TPM module (I2C bus) - TI CC2540 Bluetooth LE module (USB 2.0 bus) - 4x LED (all driven by GPIO) - 1x button (reset) - 1x USB 2.0 (optional, not installed in indoor version) - DC jack for main power input (12 V) - UART header available on PCB (2.0 mm pitch) Flash instruction: 1. This board uses dual-image feature (128 MB NAND is divided into two 64 MB partitions: 'rootfs1' and 'rootfs2'). 2. Before update, make sure your device is running firmware no older than v1.1 (previous versions have incompatible U-Boot). 3. Use 'factory' image in vendor GUI or for sysupgrade tool, without preserving settings. Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Diffstat (limited to 'target/linux/ipq40xx/image')
-rw-r--r--target/linux/ipq40xx/image/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/target/linux/ipq40xx/image/Makefile b/target/linux/ipq40xx/image/Makefile
index 31468fd758..f7e7ba3d0f 100644
--- a/target/linux/ipq40xx/image/Makefile
+++ b/target/linux/ipq40xx/image/Makefile
@@ -62,6 +62,21 @@ define Device/8dev_jalapeno
endef
TARGET_DEVICES += 8dev_jalapeno
+define Device/alfa-network_ap120c-ac
+ $(call Device/FitImage)
+ $(call Device/UbiFit)
+ DEVICE_TITLE := ALFA Network AP120C-AC
+ DEVICE_DTS := qcom-ipq4018-ap120c-ac
+ DEVICE_PACKAGES := ipq-wifi-alfa-network_ap120c-ac kmod-usb-acm \
+ kmod-tpm-i2c-atmel uboot-envtools
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ IMAGE_SIZE := 65536k
+ IMAGES := nand-factory.bin nand-sysupgrade.bin
+ IMAGE/nand-factory.bin := append-ubi | qsdk-ipq-factory-nand
+endef
+TARGET_DEVICES += alfa-network_ap120c-ac
+
define Device/asus_map-ac2200
$(call Device/FitImageLzma)
DEVICE_DTS := qcom-ipq4019-map-ac2200