aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx/image
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2018-12-20 22:55:13 +0100
committerChristian Lamparter <chunkeey@gmail.com>2018-12-20 23:54:24 +0100
commitb53111ad423ddb20c34755161a02e3923e2283d4 (patch)
treeaf5aa74654d1009dab66796ebdbd5d8d481f5cc0 /target/linux/ipq40xx/image
parent6dff3411060763557393a47fe7bacb0183717b9f (diff)
downloadupstream-b53111ad423ddb20c34755161a02e3923e2283d4.tar.gz
upstream-b53111ad423ddb20c34755161a02e3923e2283d4.tar.bz2
upstream-b53111ad423ddb20c34755161a02e3923e2283d4.zip
ipq40xx: disable kernel-padding for DNI image
This commit removes the fixed kernel size-padding for the Netgear DNI image creation as it is not necessary for a working image. The fake rootfs still needs to be padded to the blocksize. Tested-by: Christian Lamparter <chunkeey@gmail.com> Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/ipq40xx/image')
-rw-r--r--target/linux/ipq40xx/image/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/target/linux/ipq40xx/image/Makefile b/target/linux/ipq40xx/image/Makefile
index eaf9f68395..d95c151653 100644
--- a/target/linux/ipq40xx/image/Makefile
+++ b/target/linux/ipq40xx/image/Makefile
@@ -40,8 +40,8 @@ define Device/DniImage
NETGEAR_BOARD_ID :=
NETGEAR_HW_ID :=
IMAGES := factory.img sysupgrade.bin
- IMAGE/factory.img := append-kernel | pad-offset 64k 64 | append-uImage-fakehdr filesystem | pad-to $$$$(KERNEL_SIZE) | append-rootfs | pad-rootfs | netgear-dni
- IMAGE/sysupgrade.bin := append-kernel | pad-offset 64k 64 | append-uImage-fakehdr filesystem | pad-to $$$$(KERNEL_SIZE) | append-rootfs | pad-rootfs | append-metadata
+ IMAGE/factory.img := append-kernel | pad-offset 64k 64 | append-uImage-fakehdr filesystem | append-rootfs | pad-rootfs | netgear-dni
+ IMAGE/sysupgrade.bin := append-kernel | pad-offset 64k 64 | append-uImage-fakehdr filesystem | append-rootfs | pad-rootfs | append-metadata
endef
DEVICE_VARS += NETGEAR_BOARD_ID NETGEAR_HW_ID
@@ -144,7 +144,6 @@ TARGET_DEVICES += meraki_mr33
define Device/netgear_ex61x0v2
$(call Device/DniImage)
- KERNEL_SIZE := 3080192
DEVICE_DTS_CONFIG := config@4
NETGEAR_BOARD_ID := EX6150v2series
NETGEAR_HW_ID := 29765285+16+0+128+2x2