aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx/image
diff options
context:
space:
mode:
authorDaniel Danzberger <daniel@dd-wrt.com>2019-11-01 12:27:13 +0100
committerJohn Crispin <john@phrozen.org>2019-11-02 19:25:15 +0100
commitaffe633be4c8122835e255425418ba1680a652e3 (patch)
tree2eb14002f5e4fd01fbc2549b0752343cc25f9c1e /target/linux/ipq40xx/image
parent2d00cf75159938e5e8c9f26e6cdb5a4843213a3e (diff)
downloadupstream-affe633be4c8122835e255425418ba1680a652e3.tar.gz
upstream-affe633be4c8122835e255425418ba1680a652e3.tar.bz2
upstream-affe633be4c8122835e255425418ba1680a652e3.zip
ipq40xx: ipq4019: Add new device Compex WPJ419
This device contains 2 flash devices. One NOR (32M) and one NAND (128M). U-boot and caldata are on the NOR, the firmware on the NAND. SoC: IPQ4019 CPU: 4x 710MHz ARMv7 RAM: 256MB FLASH: NOR:32MB NAND:128MB ETH: 2x GMAC Gigabit POE: 802.3 af/at POE, IEEE802.3af/IEEE802.3at(48-56V) WIFI: 1x 2.4Ghz Atheros qca4019 2x2 MU-MIMO 1x 5.0Ghz Atheros qca4019 2x2 MU-MIMO USB: 1x 3.0 PCI: 1x Mini PCIe SIM: 1x Slot SD: 1x MicroSD slot BTN: Reset LED: - Power - Ethernet UART: 1x Serial Port 4 Pin Connector (UART) 1x Serial Port 6 Pin Connector (High Speed UART) POWER: 12V 2A Installation ------------ Initial flashing can only be done via u-boot using the following commands: tftpboot openwrt-ipq40xx-generic-compex_wpj419-squashfs-nand-factory.ubi nand erase.chip; nand write ${fileaddr} 0x0 ${filesize} res Signed-off-by: Daniel Danzberger <daniel@dd-wrt.com>
Diffstat (limited to 'target/linux/ipq40xx/image')
-rw-r--r--target/linux/ipq40xx/image/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/ipq40xx/image/Makefile b/target/linux/ipq40xx/image/Makefile
index ed46bca649..ef80e68393 100644
--- a/target/linux/ipq40xx/image/Makefile
+++ b/target/linux/ipq40xx/image/Makefile
@@ -164,6 +164,20 @@ define Device/avm_fritzrepeater-3000
endef
TARGET_DEVICES += avm_fritzrepeater-3000
+define Device/compex_wpj419
+ $(call Device/FitImage)
+ $(call Device/UbiFit)
+ DEVICE_VENDOR := Compex
+ DEVICE_MODEL := WPJ419
+ DEVICE_DTS := qcom-ipq4019-wpj419
+ DEVICE_DTS_CONFIG := config@12
+ KERNEL_INSTALL := 1
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ FILESYSTEMS := squashfs
+endef
+TARGET_DEVICES += compex_wpj419
+
define Device/compex_wpj428
$(call Device/FitImage)
DEVICE_VENDOR := Compex