aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx/image
diff options
context:
space:
mode:
authorOever González <notengobattery@gmail.com>2019-01-23 21:20:55 -0600
committerChristian Lamparter <chunkeey@gmail.com>2019-01-26 21:43:11 +0100
commita873b292840848b67addb5be0c762d292bde33a1 (patch)
treedf1a7df9fa65caa736df8c5bc2e43086a67b85bb /target/linux/ipq40xx/image
parent892d741259ae1f8c4b18ba8ae26c7f85f83f6340 (diff)
downloadupstream-a873b292840848b67addb5be0c762d292bde33a1.tar.gz
upstream-a873b292840848b67addb5be0c762d292bde33a1.tar.bz2
upstream-a873b292840848b67addb5be0c762d292bde33a1.zip
ipq40xx: add support for Linksys EA6350v3
Specifications: SOC: Qualcomm IPQ4018 RAM: 256 MiB Samsung K4B2G1646F-BYK0 FLASH1: MX25L1605D 2 MB FLASH2: Winbond W25N01GV 128Mb ETH: Qualcomm QCA8075 WLAN0: Qualcomm Atheros QCA4018 2.4GHz 802.11b/g/n 2x2 WLAN1: Qualcomm Atheros QCA4018 5GHz 802.11n/ac W2 2x2 INPUT: WPS, Reset LED: Status - Green SERIAL: Header at J19, Beneath DC Power Jack 1-VCC ; 2-TX ; 3-RX; 4-GND; Serial 115200-8-N-1. Tested and working: - USB (requires extra packages) - LAN Ethernet (Correct MAC-address) - WAN Ethernet (Correct MAC-address) - 2.4 GHz WiFi (Correct MAC-address) - 5 GHz WiFi (Correct MAC-address) - Factory installation from Web UI - OpenWRT sysupgrade - LED - Reset Button Need Testing: - WPS button Install via Web UI: - Attach to a LAN port on the router. - Connect to the Linksys Smart WiFi Page (default 192.168.1.1) and login - Select the connectivity tab on the left - In the manual update box on the right - Select browse, and browse to openwrt-ipq40xx-linksys_ea6350v3-squashfs-factory.bin - Click update. - Read and accept the warning - The router LED will start blinking. When the router LED goes solid, you can now navigate to 192.168.1.1 to your new OpenWrt installation. Sysupgrade: - Flash the sysupgrade image as usual. Please: try to do a reset everytime you can (doing it with LuCI is easy and can be done in the same step). Recovery (Automatic): - If the device fails to boot after install or upgrade, whilst the unit is turned on: 1 - Wait 15 seconds 2 - Switch Off and Wait 10 seconds 3 - Switch on 4 - Repeat steps 1 to 3, 3 times then go to 5. 5 - U-boot will have now erased the failed update and switched back to the last working firmware - you should be able to access your router on LAN. Recovery (Manual): - The steps for manual recovery are the same as the generic u-boot tftp client method. Back To Stock: - Use the generic recovery using the tftp client method to flash the "civic.img". Also you can strip-and-pad the original image and use the generic "mtd" method by flashing over the "kernel" partition. * Just be careful to flash in the partition that the device is currently booted. Signed-off-by: Ryan Pannell <ryan@osukl.com> Signed-off-by: Oever González <notengobattery@gmail.com> [minor edits, removed second compatible of nand, added dtb entry to 4.19] Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target/linux/ipq40xx/image')
-rw-r--r--target/linux/ipq40xx/image/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/target/linux/ipq40xx/image/Makefile b/target/linux/ipq40xx/image/Makefile
index 629a5ef48c..a670380ab3 100644
--- a/target/linux/ipq40xx/image/Makefile
+++ b/target/linux/ipq40xx/image/Makefile
@@ -26,6 +26,12 @@ define Device/FitImageLzma
KERNEL_NAME := Image
endef
+define Device/FitzImage
+ KERNEL_SUFFIX := -fit-zImage.itb
+ KERNEL = kernel-bin | fit none $$(DTS_DIR)/$$(DEVICE_DTS).dtb
+ KERNEL_NAME := zImage
+endef
+
define Device/UbiFit
KERNEL_IN_UBI := 1
IMAGES := nand-factory.ubi nand-sysupgrade.bin
@@ -131,6 +137,41 @@ define Device/glinet_gl-b1300
endef
TARGET_DEVICES += glinet_gl-b1300
+define Device/linksys_ea6350v3
+ # The Linksys EA6350v3 has a uboot bootloader that does not
+ # support either booting lzma kernel images nor booting UBI
+ # partitions. This uboot, however, supports raw kernel images and
+ # gzipped images.
+ #
+ # As for the time of writing this, the device will boot the kernel
+ # from a fixed address with a fixed length of 3MiB. Also, the
+ # device has a hard-coded kernel command line that requieres the
+ # rootfs and alt_rootfs to be in mtd11 and mtd13 respectively.
+ # Oh... and the kernel partition overlaps with the rootfs
+ # partition (the same for alt_kernel and alt_rootfs).
+ #
+ # If you are planing re-partitioning the device, you may want to
+ # keep those details in mind:
+ # 1. The kernel adresses you should honor are 0x00000000 and
+ # 0x02800000 respectively.
+ # 2. The kernel size (plus the dtb) cannot exceed 3.00MiB in size.
+ # 3. You can use 'zImage', but not a raw 'Image' packed with lzma.
+ # 4. The kernel command line from uboot is harcoded to boot with
+ # rootfs either in mtd11 or mtd13.
+ $(call Device/FitzImage)
+ DEVICE_TITLE := Linksys EA6350v3
+ DEVICE_DTS := qcom-ipq4018-ea6350v3
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ KERNEL_SIZE := 3145728
+ IMAGE_SIZE := 38797312
+ UBINIZE_OPTS := -E 5
+ IMAGES := factory.bin sysupgrade.bin
+ IMAGE/factory.bin := append-kernel | append-uImage-fakehdr filesystem | pad-to $$$${KERNEL_SIZE} | append-ubi | linksys-image type=EA6350v3
+ DEVICE_PACKAGES := ipq-wifi-linksys_ea6350v3 uboot-envtools
+endef
+TARGET_DEVICES += linksys_ea6350v3
+
define Device/meraki_mr33
$(call Device/FitImage)
DEVICE_DTS := qcom-ipq4029-mr33