aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx/image
diff options
context:
space:
mode:
authorSteven Lin <steven.lin@senao.com>2019-09-02 10:39:45 +0800
committerChristian Lamparter <chunkeey@gmail.com>2020-02-28 22:29:10 +0100
commita736d912e2bad6c470c73fbf47c45ec3017371af (patch)
tree6b4da25fb2d2f0d2c9fff5419b105f1d1402e641 /target/linux/ipq40xx/image
parent977c7f12deefc152b7d62de06f4973a54a71d746 (diff)
downloadupstream-a736d912e2bad6c470c73fbf47c45ec3017371af.tar.gz
upstream-a736d912e2bad6c470c73fbf47c45ec3017371af.tar.bz2
upstream-a736d912e2bad6c470c73fbf47c45ec3017371af.zip
ipq40xx: add support for EnGenius EAP2200
SOC: IPQ4019 / QCA Dakota CPU: Quad-Core ARMv7 Processor rev 5 (v7l) Cortex-A7 DRAM: 256 MiB FLASH: NOR 4 MiB + NAND 128 MiB ETH: Qualcomm Atheros QCA8072 WLAN1: Qualcomm Atheros QCA4019 2.4GHz 802.11bgn 2:2x2 WLAN2: Qualcomm Atheros QCA4019 5GHz 802.11a/n/ac 2:2x2 WLAN2: Qualcomm Atheros QCA9888 5GHz 802.11a/n/ac 2:2x2 INPUT: WPS Button LEDS: Power, LAN1, LAN2, WLAN 2.4GHz, WLAN 5GHz-1, WLAN 5GHz-2, OPMODE 1. Load Ramdisk via U-Boot To set up the flash memory environment, do the following: a. As a preliminary step, ensure that the board console port is connected to the PC using these RS232 parameters: * 115200bps * 8N1 b. Confirm that the PC is connected to the board using one of the Ethernet ports. c. Set a static ip 192.168.99.8 for Ethernet that connects to board. d. The PC must have a TFTP server launched and listening on the interface to which the board is connected. e. At this stage power up the board and, after a few seconds, press 4 and then any key during the countdown. U-BOOT> set serverip 192.168.99.9 && tftpboot 0x84000000 192.168.99.8:openwrt.itb && bootm Signed-off-by: Steven Lin <steven.lin@senao.com> [copied 4.19 dts to 5.4] Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target/linux/ipq40xx/image')
-rw-r--r--target/linux/ipq40xx/image/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/ipq40xx/image/Makefile b/target/linux/ipq40xx/image/Makefile
index bbe4df9df4..9ddcd17f1d 100644
--- a/target/linux/ipq40xx/image/Makefile
+++ b/target/linux/ipq40xx/image/Makefile
@@ -278,6 +278,18 @@ define Device/engenius_eap1300
endef
TARGET_DEVICES += engenius_eap1300
+define Device/engenius_eap2200
+ $(call Device/FitImage)
+ $(call Device/UbiFit)
+ DEVICE_VENDOR := EnGenius
+ DEVICE_MODEL := EAP2200
+ SOC := qcom-ipq4019
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ DEVICE_PACKAGES := ath10k-firmware-qca9888-ct ipq-wifi-engenius_eap2200 -kmod-ath10k-ct kmod-ath10k-ct-smallbuffers
+endef
+TARGET_DEVICES += engenius_eap2200
+
define Device/engenius_emd1
$(call Device/FitImage)
DEVICE_VENDOR := EnGenius