aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx/image
diff options
context:
space:
mode:
authorLuis Araneda <luaraneda@gmail.com>2019-07-06 00:50:32 -0400
committerDaniel Golle <daniel@makrotopia.org>2019-07-10 16:57:52 +0200
commit87552e54002701511bfee5264284289d74372a2e (patch)
tree77276eed3923ed7fc2ee2d780974bad3291c93e7 /target/linux/ipq40xx/image
parent5850487473cbd7eaa505d6a03d35f90a00f8710b (diff)
downloadupstream-87552e54002701511bfee5264284289d74372a2e.tar.gz
upstream-87552e54002701511bfee5264284289d74372a2e.tar.bz2
upstream-87552e54002701511bfee5264284289d74372a2e.zip
ipq40xx: convert to multi-variable device title
Additionally, fix some vendor and board names Signed-off-by: Luis Araneda <luaraneda@gmail.com>
Diffstat (limited to 'target/linux/ipq40xx/image')
-rw-r--r--target/linux/ipq40xx/image/Makefile79
1 files changed, 55 insertions, 24 deletions
diff --git a/target/linux/ipq40xx/image/Makefile b/target/linux/ipq40xx/image/Makefile
index 3a9b58de4f..567f91d4d7 100644
--- a/target/linux/ipq40xx/image/Makefile
+++ b/target/linux/ipq40xx/image/Makefile
@@ -63,17 +63,19 @@ endef
define Device/8dev_jalapeno
$(call Device/FitImage)
$(call Device/UbiFit)
+ DEVICE_VENDOR := 8devices
+ DEVICE_MODEL := Jalapeno
DEVICE_DTS := qcom-ipq4018-jalapeno
BLOCKSIZE := 128k
PAGESIZE := 2048
- DEVICE_TITLE := 8devices Jalapeno
endef
TARGET_DEVICES += 8dev_jalapeno
define Device/alfa-network_ap120c-ac
$(call Device/FitImage)
$(call Device/UbiFit)
- DEVICE_TITLE := ALFA Network AP120C-AC
+ DEVICE_VENDOR := ALFA Network
+ DEVICE_MODEL := AP120C-AC
DEVICE_DTS := qcom-ipq4018-ap120c-ac
DEVICE_PACKAGES := ipq-wifi-alfa-network_ap120c-ac kmod-usb-acm \
kmod-tpm-i2c-atmel uboot-envtools
@@ -87,8 +89,9 @@ TARGET_DEVICES += alfa-network_ap120c-ac
define Device/asus_map-ac2200
$(call Device/FitImageLzma)
+ DEVICE_VENDOR := ASUS
+ DEVICE_MODEL := Lyra (MAP-AC2200)
DEVICE_DTS := qcom-ipq4019-map-ac2200
- DEVICE_TITLE := ASUS Lyra MAP-AC2200
IMAGES := sysupgrade.bin
DEVICE_PACKAGES := ipq-wifi-asus_map-ac2200 ath10k-firmware-qca9888-ct kmod-ath3k
endef
@@ -96,11 +99,12 @@ TARGET_DEVICES += asus_map-ac2200
define Device/asus_rt-ac58u
$(call Device/FitImageLzma)
+ DEVICE_VENDOR := ASUS
+ DEVICE_MODEL := RT-AC58U
DEVICE_DTS := qcom-ipq4018-rt-ac58u
BLOCKSIZE := 128k
PAGESIZE := 2048
DTB_SIZE := 65536
- DEVICE_TITLE := Asus RT-AC58U
IMAGE_SIZE := 20439364
FILESYSTEMS := squashfs
# Someone - in their infinite wisdom - decided to put the firmware
@@ -116,9 +120,10 @@ TARGET_DEVICES += asus_rt-ac58u
define Device/avm_fritzbox-4040
$(call Device/FitImageLzma)
+ DEVICE_VENDOR := AVM
+ DEVICE_MODEL := FRITZ!Box 4040
DEVICE_DTS := qcom-ipq4018-fritz4040
BOARD_NAME := fritz4040
- DEVICE_TITLE := AVM Fritz!Box 4040
IMAGE_SIZE := 29753344
UBOOT_PATH := $(STAGING_DIR_IMAGE)/uboot-fritz4040.bin
UBOOT_PARTITION_SIZE := 524288
@@ -131,8 +136,9 @@ TARGET_DEVICES += avm_fritzbox-4040
define Device/avm_fritzbox-7530
$(call Device/FitImageLzma)
+ DEVICE_VENDOR := AVM
+ DEVICE_MODEL := FRITZ!Box 7530
DEVICE_DTS := qcom-ipq4019-fritzbox-7530
- DEVICE_TITLE := AVM Fritz!Box 7530
DEVICE_PACKAGES := fritz-caldata fritz-tffs-nand ipq-wifi-avm_fritzbox-7530
IMAGES := sysupgrade.bin
endef
@@ -140,8 +146,9 @@ TARGET_DEVICES += avm_fritzbox-7530
define Device/avm_fritzrepeater-3000
$(call Device/FitImageLzma)
+ DEVICE_VENDOR := AVM
+ DEVICE_MODEL := FRITZ!Repeater 3000
DEVICE_DTS := qcom-ipq4019-fritzrepeater-3000
- DEVICE_TITLE := AVM Fritz!Repeater 3000
DEVICE_PACKAGES := ath10k-firmware-qca9984-ct fritz-caldata fritz-tffs-nand ipq-wifi-avm_fritzrepeater-3000
IMAGES := sysupgrade.bin
endef
@@ -149,10 +156,11 @@ TARGET_DEVICES += avm_fritzrepeater-3000
define Device/compex_wpj428
$(call Device/FitImage)
+ DEVICE_VENDOR := Compex
+ DEVICE_MODEL := WPJ428
DEVICE_DTS := qcom-ipq4028-wpj428
DEVICE_DTS_CONFIG := config@4
BLOCKSIZE := 64k
- DEVICE_TITLE := Compex WPJ428
IMAGE_SIZE := 31232k
KERNEL_SIZE := 4096k
IMAGES = sysupgrade.bin
@@ -163,7 +171,8 @@ TARGET_DEVICES += compex_wpj428
define Device/engenius_eap1300
$(call Device/FitImage)
- DEVICE_TITLE := EnGenius EAP1300
+ DEVICE_VENDOR := EnGenius
+ DEVICE_MODEL := EAP1300
DEVICE_DTS_CONFIG := config@4
BOARD_NAME := eap1300
DEVICE_DTS := qcom-ipq4018-eap1300
@@ -177,11 +186,12 @@ TARGET_DEVICES += engenius_eap1300
define Device/engenius_ens620ext
$(call Device/FitImage)
+ DEVICE_VENDOR := EnGenius
+ DEVICE_MODEL := ENS620EXT
DEVICE_DTS := qcom-ipq4018-ens620ext
DEVICE_DTS_CONFIG := config@4
BLOCKSIZE := 64k
PAGESIZE := 256
- DEVICE_TITLE := EnGenius ENS620EXT
BOARD_NAME := ENS620EXT
VENDOR_ID := 0x0101
PRODUCT_ID := 0x79
@@ -203,7 +213,8 @@ TARGET_DEVICES += engenius_ens620ext
define Device/glinet_gl-b1300
$(call Device/FitImage)
- DEVICE_TITLE := GL.iNet GL-B1300
+ DEVICE_VENDOR := GL.iNet
+ DEVICE_MODEL := GL-B1300
BOARD_NAME := gl-b1300
DEVICE_DTS := qcom-ipq4029-gl-b1300
KERNEL_SIZE := 4096k
@@ -235,7 +246,9 @@ define Device/linksys_ea6350v3
# 4. The kernel command line from uboot is harcoded to boot with
# rootfs either in mtd11 or mtd13.
$(call Device/FitzImage)
- DEVICE_TITLE := Linksys EA6350v3
+ DEVICE_VENDOR := Linksys
+ DEVICE_MODEL := EA6350
+ DEVICE_VARIANT := v3
DEVICE_DTS := qcom-ipq4018-ea6350v3
BLOCKSIZE := 128k
PAGESIZE := 2048
@@ -250,7 +263,8 @@ TARGET_DEVICES += linksys_ea6350v3
define Device/linksys_ea8300
$(call Device/FitzImage)
- DEVICE_TITLE := Linksys EA8300 (Dallas)
+ DEVICE_VENDOR := Linksys
+ DEVICE_MODEL := EA8300
DEVICE_DTS := qcom-ipq4019-linksys_ea8300
KERNEL_SIZE := 3072k
IMAGE_SIZE := 87040k
@@ -265,10 +279,11 @@ TARGET_DEVICES += linksys_ea8300
define Device/meraki_mr33
$(call Device/FitImage)
+ DEVICE_VENDOR := Cisco Meraki
+ DEVICE_MODEL := MR33
DEVICE_DTS := qcom-ipq4029-mr33
BLOCKSIZE := 131072
PAGESIZE := 2048
- DEVICE_TITLE := Cisco Meraki MR33
IMAGES = sysupgrade.bin
DEVICE_PACKAGES := -swconfig ath10k-firmware-qca9887-ct
endef
@@ -283,24 +298,29 @@ endef
define Device/netgear_ex6100v2
$(call Device/netgear_ex61x0v2)
+ DEVICE_VENDOR := Netgear
+ DEVICE_MODEL := EX6100
+ DEVICE_VARIANT := v2
DEVICE_DTS := qcom-ipq4018-ex6100v2
- DEVICE_TITLE := Netgear EX6100v2
endef
TARGET_DEVICES += netgear_ex6100v2
define Device/netgear_ex6150v2
$(call Device/netgear_ex61x0v2)
+ DEVICE_VENDOR := Netgear
+ DEVICE_MODEL := EX6150
+ DEVICE_VARIANT := v2
DEVICE_DTS := qcom-ipq4018-ex6150v2
- DEVICE_TITLE := Netgear EX6150v2
endef
TARGET_DEVICES += netgear_ex6150v2
define Device/openmesh_a42
$(call Device/FitImageLzma)
+ DEVICE_VENDOR := OpenMesh
+ DEVICE_MODEL := A42
DEVICE_DTS := qcom-ipq4018-a42
DEVICE_DTS_CONFIG := config@om.a42
BLOCKSIZE := 64k
- DEVICE_TITLE := OpenMesh A42
KERNEL = kernel-bin | lzma | fit lzma $$(DTS_DIR)/$$(DEVICE_DTS).dtb | pad-to $$(BLOCKSIZE)
IMAGE_SIZE := 15616k
IMAGES = factory.bin sysupgrade.bin
@@ -312,10 +332,11 @@ TARGET_DEVICES += openmesh_a42
define Device/openmesh_a62
$(call Device/FitImageLzma)
+ DEVICE_VENDOR := OpenMesh
+ DEVICE_MODEL := A62
DEVICE_DTS := qcom-ipq4019-a62
DEVICE_DTS_CONFIG := config@om.a62
BLOCKSIZE := 64k
- DEVICE_TITLE := OpenMesh A62
KERNEL = kernel-bin | lzma | fit lzma $$(DTS_DIR)/$$(DEVICE_DTS).dtb | pad-to $$(BLOCKSIZE)
IMAGE_SIZE := 15552k
IMAGES = factory.bin sysupgrade.bin
@@ -327,7 +348,9 @@ endef
TARGET_DEVICES += openmesh_a62
define Device/qcom_ap-dk01.1-c1
- DEVICE_TITLE := QCA AP-DK01.1-C1
+ DEVICE_VENDOR := Qualcomm Atheros
+ DEVICE_MODEL := AP-DK01.1
+ DEVICE_VARIANT := C1
BOARD_NAME := ap-dk01.1-c1
DEVICE_DTS := qcom-ipq4019-ap.dk01.1-c1
KERNEL_INSTALL := 1
@@ -342,19 +365,23 @@ TARGET_DEVICES += qcom_ap-dk01.1-c1
define Device/qcom_ap-dk04.1-c1
$(call Device/FitImage)
$(call Device/UbiFit)
+ DEVICE_VENDOR := Qualcomm Atheros
+ DEVICE_MODEL := AP-DK04.1
+ DEVICE_VARIANT := C1
DEVICE_DTS := qcom-ipq4019-ap.dk04.1-c1
KERNEL_INSTALL := 1
KERNEL_SIZE := 4048k
BLOCKSIZE := 128k
PAGESIZE := 2048
BOARD_NAME := ap-dk04.1-c1
- DEVICE_TITLE := QCA AP-DK04.1-C1
endef
TARGET_DEVICES += qcom_ap-dk04.1-c1
define Device/qxwlan_e2600ac-c1
$(call Device/FitImage)
- DEVICE_TITLE := Qxwlan E2600AC-C1 (nor flash)
+ DEVICE_VENDOR := Qxwlan
+ DEVICE_MODEL := E2600AC
+ DEVICE_VARIANT := C1
BOARD_NAME := e2600ac-c1
DEVICE_DTS := qcom-ipq4019-qxwlan-e2600ac-c1
KERNEL_SIZE := 4096k
@@ -368,19 +395,22 @@ TARGET_DEVICES += qxwlan_e2600ac-c1
define Device/qxwlan_e2600ac-c2
$(call Device/FitImage)
$(call Device/UbiFit)
+ DEVICE_VENDOR := Qxwlan
+ DEVICE_MODEL := E2600AC
+ DEVICE_VARIANT := C2
DEVICE_DTS := qcom-ipq4019-qxwlan-e2600ac-c2
KERNEL_INSTALL := 1
BLOCKSIZE := 128k
PAGESIZE := 2048
- DEVICE_TITLE := Qxwlan E2600AC-C2 (nornand flash)
DEVICE_PACKAGES := ipq-wifi-qxwlan_e2600ac
endef
TARGET_DEVICES += qxwlan_e2600ac-c2
define Device/zyxel_nbg6617
$(call Device/FitImageLzma)
+ DEVICE_VENDOR := ZyXEL
+ DEVICE_MODEL := NBG6617
DEVICE_DTS := qcom-ipq4018-nbg6617
- DEVICE_TITLE := ZyXEL NBG6617
ROOTFS_SIZE := 24960k
RAS_BOARD := NBG6617
RAS_ROOTFS_SIZE := 19840k
@@ -399,7 +429,8 @@ TARGET_DEVICES += zyxel_nbg6617
define Device/zyxel_wre6606
$(call Device/FitImage)
- DEVICE_TITLE := ZyXEL WRE6606
+ DEVICE_VENDOR := ZyXEL
+ DEVICE_MODEL := WRE6606
DEVICE_DTS_CONFIG := config@4
DEVICE_DTS := qcom-ipq4018-wre6606
IMAGES := sysupgrade.bin