aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx/image
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2019-09-10 21:07:23 +0200
committerDavid Bauer <mail@david-bauer.net>2019-10-23 01:17:28 +0200
commit7f187229a8e9b7966248b1e024217e07a9fc3e50 (patch)
treeebfd222079b43f5a95365ee73223788a13256f8e /target/linux/ipq40xx/image
parentc0f40781645297ad68678e3de2557b611e9f785c (diff)
downloadupstream-7f187229a8e9b7966248b1e024217e07a9fc3e50.tar.gz
upstream-7f187229a8e9b7966248b1e024217e07a9fc3e50.tar.bz2
upstream-7f187229a8e9b7966248b1e024217e07a9fc3e50.zip
ipq40xx: add support for AVM FRITZ!Repeater 1200
Hardware -------- SoC: Qualcomm IPQ4019 RAM: 256M DDR3 FLASH: 128M NAND WiFi: 2T2R IPQ4019 bgn 2T2R IPQ4019 a/n/ac ETH: Atheros AR8033 RGMII PHY BTN: 1x Connect (WPS) LED: Power (green/red/yellow) Installation ------------ 1. Grab the uboot for the Device from the 'u-boot-fritz1200' subdirectory. Place it in the same directory as the 'eva_ramboot.py' script. It is located in the 'scripts/flashing' subdirectory of the OpenWRT tree. 2. Assign yourself the IP address 192.168.178.10/24. Connect your Computer to one of the boxes LAN ports. 3. Connect Power to the Box. As soon as the LAN port of your computer shows link, load the U-Boot to the box using following command. > ./eva_ramboot.py --offset 0x85000000 192.168.178.1 uboot-fritz1200.bin 4. The U-Boot will now start. Now assign yourself the IP address 192.168.1.70/24. Copy the OpenWRT initramfs (!) image to a TFTP server root directory and rename it to 'FRITZ1200.bin'. 5. The Box will now boot OpenWRT from RAM. This can take up to two minutes. 6. Copy the U-Boot and the OpenWRT sysupgrade (!) image to the Box using scp. SSH into the Box and first write the Bootloader to both previous kernel partitions. > mtd write /path/to/uboot-fritz1200.bin uboot0 > mtd write /path/to/uboot-fritz1200.bin uboot1 7. Remove the AVM filesystem partitions to make room for our kernel + rootfs + overlayfs. > ubirmvol /dev/ubi0 --name=avm_filesys_0 > ubirmvol /dev/ubi0 --name=avm_filesys_1 8. Flash OpenWRT peristently using sysupgrade. > sysupgrade -n /path/to/openwrt-sysupgrade.bin Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/ipq40xx/image')
-rw-r--r--target/linux/ipq40xx/image/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ipq40xx/image/Makefile b/target/linux/ipq40xx/image/Makefile
index 8907eb756b..5b460d1c1f 100644
--- a/target/linux/ipq40xx/image/Makefile
+++ b/target/linux/ipq40xx/image/Makefile
@@ -144,6 +144,16 @@ define Device/avm_fritzbox-7530
endef
TARGET_DEVICES += avm_fritzbox-7530
+define Device/avm_fritzrepeater-1200
+ $(call Device/FitImageLzma)
+ DEVICE_VENDOR := AVM
+ DEVICE_MODEL := FRITZ!Repeater 1200
+ DEVICE_DTS := qcom-ipq4019-fritzrepeater-1200
+ DEVICE_PACKAGES := fritz-caldata fritz-tffs-nand ipq-wifi-avm_fritzrepeater-1200
+ IMAGES := sysupgrade.bin
+endef
+TARGET_DEVICES += avm_fritzrepeater-1200
+
define Device/avm_fritzrepeater-3000
$(call Device/FitImageLzma)
DEVICE_VENDOR := AVM