aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx/image
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2018-04-20 06:30:46 +0200
committerMathias Kresin <dev@kresin.me>2018-04-20 20:58:52 +0200
commit74a0d8cd92c7e753c6a342a7b90151ec042a03c5 (patch)
treef0fb63e26b872c1e799d8cf729182df3a2d8861d /target/linux/ipq40xx/image
parent5950ab067bcc6ffa9ab6bb0c28c8d9ca45d34eb7 (diff)
downloadupstream-74a0d8cd92c7e753c6a342a7b90151ec042a03c5.tar.gz
upstream-74a0d8cd92c7e753c6a342a7b90151ec042a03c5.tar.bz2
upstream-74a0d8cd92c7e753c6a342a7b90151ec042a03c5.zip
build: consolidate fake uImage header build commands
Merge the two existing functions and use a parameter for the type header field. It updates the syntax of the former mpc85xx fake ramdisk header command to be compatible with mkimage from u-boot 2018.03 and fixes the build error spotted by the build bot. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/ipq40xx/image')
-rw-r--r--target/linux/ipq40xx/image/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/ipq40xx/image/Makefile b/target/linux/ipq40xx/image/Makefile
index 058cab3399..b305ea0960 100644
--- a/target/linux/ipq40xx/image/Makefile
+++ b/target/linux/ipq40xx/image/Makefile
@@ -38,8 +38,8 @@ define Device/DniImage
NETGEAR_BOARD_ID :=
NETGEAR_HW_ID :=
IMAGES := factory.img sysupgrade.bin
- IMAGE/factory.img := append-kernel | pad-offset 64k 64 | append-uImage-fakeroot-hdr | pad-to $$$$(KERNEL_SIZE) | append-rootfs | pad-rootfs | netgear-dni
- IMAGE/sysupgrade.bin := append-kernel | pad-offset 64k 64 | append-uImage-fakeroot-hdr | pad-to $$$$(KERNEL_SIZE) | append-rootfs | pad-rootfs | append-metadata
+ IMAGE/factory.img := append-kernel | pad-offset 64k 64 | append-uImage-fakehdr filesystem | pad-to $$$$(KERNEL_SIZE) | append-rootfs | pad-rootfs | netgear-dni
+ IMAGE/sysupgrade.bin := append-kernel | pad-offset 64k 64 | append-uImage-fakehdr filesystem | pad-to $$$$(KERNEL_SIZE) | append-rootfs | pad-rootfs | append-metadata
endef
DEVICE_VARS += NETGEAR_BOARD_ID NETGEAR_HW_ID