aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx/image
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2018-05-16 01:57:16 +0200
committerJohn Crispin <john@phrozen.org>2018-05-22 20:34:14 +0200
commit70e6ea319d3bfdfdb34be540dc7d89aa175b5587 (patch)
treedb34de490d8864b87ec59b3a6b0550759733c093 /target/linux/ipq40xx/image
parent399495a952bf687d9c59226bddf4e73d3b42b30c (diff)
downloadupstream-70e6ea319d3bfdfdb34be540dc7d89aa175b5587.tar.gz
upstream-70e6ea319d3bfdfdb34be540dc7d89aa175b5587.tar.bz2
upstream-70e6ea319d3bfdfdb34be540dc7d89aa175b5587.zip
ipq40xx: add eva-image for FRITZ!Box 4040
This commit adds an EVA flashable image for the FRITZ!Box 4040. The image contains the U-Boot with OpenWRT appended to it. This way we remove the need to use UART for initial flashing. Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/ipq40xx/image')
-rw-r--r--target/linux/ipq40xx/image/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/target/linux/ipq40xx/image/Makefile b/target/linux/ipq40xx/image/Makefile
index be396f92da..8ba2697e4f 100644
--- a/target/linux/ipq40xx/image/Makefile
+++ b/target/linux/ipq40xx/image/Makefile
@@ -80,7 +80,10 @@ define Device/avm_fritzbox-4040
BOARD_NAME := fritz4040
DEVICE_TITLE := AVM Fritz!Box 4040
IMAGE_SIZE := 29753344
- IMAGES = sysupgrade.bin
+ UBOOT_PATH := $$(BIN_DIR)/u-boot-fritz4040/uboot-fritz4040.bin
+ UBOOT_PARTITION_SIZE := 524288
+ IMAGES = eva.bin sysupgrade.bin
+ IMAGE/eva.bin := append-uboot | pad-to $$$$(UBOOT_PARTITION_SIZE) | append-kernel | append-rootfs | pad-rootfs
IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
DEVICE_PACKAGES := fritz-tffs fritz-caldata u-boot-fritz4040
endef