aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx/image
diff options
context:
space:
mode:
authorYen-Ting-Shen <frank.shen@senao.com>2019-11-01 14:00:40 +0800
committerChristian Lamparter <chunkeey@gmail.com>2020-01-26 01:20:45 +0100
commit51f30359783938a1be7ffbd08e508c1b6c9c449f (patch)
treef5e859036259e4a01e4b0686fb88155e781675e1 /target/linux/ipq40xx/image
parent52b8c7a8928ccdc80436c76955f237960ea3bf1f (diff)
downloadupstream-51f30359783938a1be7ffbd08e508c1b6c9c449f.tar.gz
upstream-51f30359783938a1be7ffbd08e508c1b6c9c449f.tar.bz2
upstream-51f30359783938a1be7ffbd08e508c1b6c9c449f.zip
ipq40xx: add support for EnGenius EMD1
SOC: IPQ4018 / QCA Dakota CPU: Quad-Core ARMv7 Processor rev 5 (v7l) Cortex-A7 DRAM: 256 MiB NOR: 32 MiB ETH: Qualcomm Atheros QCA8072 (1 port) WLAN1: Qualcomm Atheros QCA4018 2.4GHz 802.11bgn 2:2x2 WLAN2: Qualcomm Atheros QCA4018 5GHz 802.11a/n/ac 2:2x2 INPUT: RESET Button LEDS: White, Blue, Red, Orange Flash instruction: From EnGenius firmware to OpenWrt firmware: In Firmware Upgrade page, upgrade your openwrt-ipq40xx-generic-engenius_emd1-squashfs-factory.bin directly. From OpenWrt firmware to EnGenius firmware: 1. Setup a TFTP server on your computer and configure static IP to 192.168.99.8 Put the EnGenius firmware in the TFTP server directory on your computer. 2. Power up EMD1. Press 4 and then press any key to enter u-boot. 3. Download EnGenius firmware (IPQ40xx) # tftpboot 0x84000000 openwrt-ipq40xx-emd1-nor-fw-s.img 4. Flash the firmware (IPQ40xx) # imgaddr=0x84000000 && source 0x84000000:script 5. Reboot (IPQ40xx) # reset Signed-off-by: Yen-Ting-Shen <frank.shen@senao.com> [removed BOARD_NAME] Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target/linux/ipq40xx/image')
-rw-r--r--target/linux/ipq40xx/image/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/ipq40xx/image/Makefile b/target/linux/ipq40xx/image/Makefile
index 41a65280c3..bbe4df9df4 100644
--- a/target/linux/ipq40xx/image/Makefile
+++ b/target/linux/ipq40xx/image/Makefile
@@ -278,6 +278,19 @@ define Device/engenius_eap1300
endef
TARGET_DEVICES += engenius_eap1300
+define Device/engenius_emd1
+ $(call Device/FitImage)
+ DEVICE_VENDOR := EnGenius
+ DEVICE_MODEL := EMD1
+ DEVICE_DTS_CONFIG := config@4
+ SOC := qcom-ipq4018
+ IMAGE_SIZE := 30720k
+ IMAGES := sysupgrade.bin factory.bin
+ IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
+ IMAGE/factory.bin := qsdk-ipq-factory-nor | check-size $$$$(IMAGE_SIZE)
+endef
+TARGET_DEVICES += engenius_emd1
+
define Device/engenius_ens620ext
$(call Device/FitImage)
DEVICE_VENDOR := EnGenius