aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx/image
diff options
context:
space:
mode:
authorSteven Lin <steven.lin@senao.com>2018-10-19 16:55:08 +0800
committerMathias Kresin <dev@kresin.me>2018-12-05 09:40:32 +0100
commit2b4ac79a791d9451f601d494dde2e71864174358 (patch)
treeefdddf6c8757a2f19f4998ef1e1a25e152a81b79 /target/linux/ipq40xx/image
parente261c8b76407ebd2d8289e3522bd02e5bd6e8552 (diff)
downloadupstream-2b4ac79a791d9451f601d494dde2e71864174358.tar.gz
upstream-2b4ac79a791d9451f601d494dde2e71864174358.tar.bz2
upstream-2b4ac79a791d9451f601d494dde2e71864174358.zip
ipq40xx: add support for EnGenius EAP1300
SOC: IPQ4018 / QCA Dakota CPU: Quad-Core ARMv7 Processor rev 5 (v7l) Cortex-A7 DRAM: 256 MiB NOR: 32 MiB ETH: Qualcomm Atheros QCA8072 WLAN1: Qualcomm Atheros QCA4018 2.4GHz 802.11bgn 2:2x2 WLAN2: Qualcomm Atheros QCA4018 5GHz 802.11a/n/ac 2:2x2 INPUT: RESET Button LEDS: Power, LAN, MESH, WLAN 2.4GHz, WLAN 5GHz 1. Load Ramdisk via U-Boot To set up the flash memory environment, do the following: a. As a preliminary step, ensure that the board console port is connected to the PC using these RS232 parameters: * 115200bps * 8N1 b. Confirm that the PC is connected to the board using one of the Ethernet ports. Set a static ip 192.168.99.8 for Ethernet that connects to board. The PC must have a TFTP server launched and listening on the interface to which the board is connected. At this stage power up the board and, after a few seconds, press 4 and then any key during the countdown. U-BOOT> set serverip 192.168.99.8 && set ipaddr 192.168.99.9 && tftpboot 0x84000000 openwrt.itb && bootm 2. Load image via GUI a. Upgrade EAP1300 to FW v3.5.3.2 In the GUI, System Manager > Firmware > Firmware Upgrade, to do upgrade. b. Transfer to OpenWrt from EnGenius. In Firmware Upgrade page, to upgrade yours openwrt-ipq40xx-engenius_eap1300-squashfs-sysupgrade.bin. 3. Revert to EnGenius EAP1300 To flash openwrt-ipq40xx-engenius_eap1300-squashfs-factory.bin by using sysupgrade command and "DO NOT" keep configuration. $ sysupgrade –n openwrt-ipq40xx-engenius_eap1300-squashfs-factory.bin Signed-off-by: Steven Lin <steven.lin@senao.com>
Diffstat (limited to 'target/linux/ipq40xx/image')
-rw-r--r--target/linux/ipq40xx/image/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/ipq40xx/image/Makefile b/target/linux/ipq40xx/image/Makefile
index 8a42d3e780..eaf9f68395 100644
--- a/target/linux/ipq40xx/image/Makefile
+++ b/target/linux/ipq40xx/image/Makefile
@@ -105,6 +105,20 @@ define Device/compex_wpj428
endef
TARGET_DEVICES += compex_wpj428
+define Device/engenius_eap1300
+ $(call Device/FitImage)
+ DEVICE_TITLE := EnGenius EAP1300
+ DEVICE_DTS_CONFIG := config@4
+ BOARD_NAME := eap1300
+ DEVICE_DTS := qcom-ipq4018-eap1300
+ KERNEL_SIZE := 5120k
+ IMAGE_SIZE := 25344k
+ IMAGES := sysupgrade.bin
+ IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
+ DEVICE_PACKAGES := ipq-wifi-engenius_eap1300
+endef
+TARGET_DEVICES += engenius_eap1300
+
define Device/glinet_gl-b1300
$(call Device/FitImage)
DEVICE_TITLE := GL.iNet GL-B1300