aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx/image
diff options
context:
space:
mode:
authorRobert Marko <robert@meshpoint.me>2019-11-25 15:25:00 +0100
committerPetr Štetiar <ynezz@true.cz>2019-11-30 00:53:36 +0100
commit146eb4925c7f32650f38cb52139696a827051700 (patch)
tree84ea789ac596c8cb56041eabd75f8a03a6cfde46 /target/linux/ipq40xx/image
parentc550b1acfc8105b3dcdca207410c45fbaf360fca (diff)
downloadupstream-146eb4925c7f32650f38cb52139696a827051700.tar.gz
upstream-146eb4925c7f32650f38cb52139696a827051700.tar.bz2
upstream-146eb4925c7f32650f38cb52139696a827051700.zip
ipq40xx: add support for Crisis Innovation Lab MeshPoint.One
MeshPoint.One is Wi-Fi hotspot and smart IoT gateway (based upon Jalapeno module from 8Devices). MeshPoint.One (https://meshpointone.com) is a unique Wi-Fi hotspot and smart city gateway that can be installed and powered from street lighting (even solar power in the future). MeshPoint provides up to 27 hours of interrupted Wi-Fi and IoT services from internal battery even when external power is not available. MeshPoint.One can be used for disaster relief efforts in order to provide instant Wi-Fi coverage that can be easily expanded by just adding more devices that create wide area mesh network. MeshPoint.One devices have standard Luci UI for management. Features: - 1x 1Gpbs WAN - 1x 1Gbps LAN - POE input (eth0) - POE output (eth1) - Sensor for temperature, humidity and pressure (Bosch BME280) - current, voltage and power measurement via TI INA230 - Hardware real time clock - optional power via Li-Ion battery - micro USB port with USB to serial chip for easy OpenWrt terminal access - I2C header for connecting additional sensors Installation: ------------- Simply flash the sysupgrade image from stock firmware. Or use the built in Web recovery into bootloader: Hold Reset button for 5 to 20 seconds or use UART and httpd command. Web UI will appear on 192.168.2.100 by default. For web recovery use the factory.ubi image. Signed-off-by: Damir Samardzic <damir.samardzic@sartura.hr> Signed-off-by: Damir Franusic <damir.franusic@sartura.hr> Signed-off-by: Valent Turkovic <valent@meshpoint.me> Signed-off-by: Robert Marko <robert@meshpoint.me> [commit description long line wrap, usb->USB] Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'target/linux/ipq40xx/image')
-rw-r--r--target/linux/ipq40xx/image/Makefile19
1 files changed, 16 insertions, 3 deletions
diff --git a/target/linux/ipq40xx/image/Makefile b/target/linux/ipq40xx/image/Makefile
index a9c5e625af..ac34447475 100644
--- a/target/linux/ipq40xx/image/Makefile
+++ b/target/linux/ipq40xx/image/Makefile
@@ -60,14 +60,18 @@ define Build/SenaoFW
@cp $@.new $@
endef
-define Device/8dev_jalapeno
+define Device/8dev_jalapeno-common
$(call Device/FitImage)
$(call Device/UbiFit)
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+endef
+
+define Device/8dev_jalapeno
+ $(call Device/8dev_jalapeno-common)
DEVICE_VENDOR := 8devices
DEVICE_MODEL := Jalapeno
DEVICE_DTS := qcom-ipq4018-jalapeno
- BLOCKSIZE := 128k
- PAGESIZE := 2048
endef
TARGET_DEVICES += 8dev_jalapeno
@@ -164,6 +168,15 @@ define Device/avm_fritzrepeater-3000
endef
TARGET_DEVICES += avm_fritzrepeater-3000
+define Device/cilab_meshpoint-one
+ $(call Device/8dev_jalapeno-common)
+ DEVICE_DTS := qcom-ipq4018-meshpoint-one
+ DEVICE_VENDOR := Crisis Innovation Lab
+ DEVICE_MODEL := MeshPoint.One
+ DEVICE_PACKAGES := kmod-i2c-gpio kmod-iio-bmp280-i2c kmod-hwmon-ina2xx kmod-rtc-pcf2127
+endef
+TARGET_DEVICES += cilab_meshpoint-one
+
define Device/compex_wpj419
$(call Device/FitImage)
$(call Device/UbiFit)