aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx/image/generic.mk
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2021-08-18 16:11:11 +0300
committerStijn Tintel <stijn@linux-ipv6.be>2021-08-18 16:11:11 +0300
commita43da1be43ae251f0edaa6419612e600fc6ec972 (patch)
tree62c47d11c259210a277cb2987b15c90921e4280c /target/linux/ipq40xx/image/generic.mk
parentefca67983d4fc01c14619efcaa632220bd28826e (diff)
downloadupstream-a43da1be43ae251f0edaa6419612e600fc6ec972.tar.gz
upstream-a43da1be43ae251f0edaa6419612e600fc6ec972.tar.bz2
upstream-a43da1be43ae251f0edaa6419612e600fc6ec972.zip
ipq40xx: fix Edgecore ECW5211 boot
The bootloader will look for a configuration section named ap.dk01.1-c2 in the FIT image. If this doesn't exist, the device won't boot. Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Diffstat (limited to 'target/linux/ipq40xx/image/generic.mk')
-rw-r--r--target/linux/ipq40xx/image/generic.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/linux/ipq40xx/image/generic.mk b/target/linux/ipq40xx/image/generic.mk
index 9dee742eb4..c7e3583613 100644
--- a/target/linux/ipq40xx/image/generic.mk
+++ b/target/linux/ipq40xx/image/generic.mk
@@ -365,6 +365,7 @@ define Device/edgecore_ecw5211
SOC := qcom-ipq4018
BLOCKSIZE := 128k
PAGESIZE := 2048
+ DEVICE_DTS_CONFIG := config@ap.dk01.1-c2
DEVICE_PACKAGES := kmod-tpm-i2c-atmel kmod-usb-acm
endef
TARGET_DEVICES += edgecore_ecw5211