aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx/image/generic.mk
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2022-05-13 22:25:36 +0200
committerChristian Lamparter <chunkeey@gmail.com>2022-05-14 11:08:45 +0200
commit91fa4826b975943daab97df450ca65a5bff8bbed (patch)
treef40df24edf141639b18fe9af3c6e22b1fe5094fa /target/linux/ipq40xx/image/generic.mk
parent4ba7f6d9cbd74adc82ab3064cc4c9f6ec5eb51a6 (diff)
downloadupstream-91fa4826b975943daab97df450ca65a5bff8bbed.tar.gz
upstream-91fa4826b975943daab97df450ca65a5bff8bbed.tar.bz2
upstream-91fa4826b975943daab97df450ca65a5bff8bbed.zip
ipq-wifi: drop upstreamed board-2.bin
The BDFs for the: Aruba AP-303 ASUS RT-AC42U AVM FRITZ!Repeater 1200 Buffalo WTR-M2133HP Cell C RTL30VW D-Link DAP-2610 EnGenius EAP2200 EnGenius EMD1 EnGenius EMR3500 EnGenius EMR5000 EZVIZ CS-W3-WD1200G EUP Google Wifi Linksys MR8300 V1.0 Luma WRTQ-329ACN MobiPromo CM520-79F NEC Platforms WG2600HP3 Plasma Cloud PA1200 (updated version) Plasma Cloud PA2200 ZTE MF286D were upstreamed to the ath10k-firmware repository and landed in linux-firmware.git. Furthermore the BDFs for the: 8devices Habanero OpenMesh A62 OpenMesh A42 AVM FRITZ!Box 4040 have been updated. Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target/linux/ipq40xx/image/generic.mk')
-rw-r--r--target/linux/ipq40xx/image/generic.mk29
1 files changed, 11 insertions, 18 deletions
diff --git a/target/linux/ipq40xx/image/generic.mk b/target/linux/ipq40xx/image/generic.mk
index 5eac14e0ae..b730a0e184 100644
--- a/target/linux/ipq40xx/image/generic.mk
+++ b/target/linux/ipq40xx/image/generic.mk
@@ -130,7 +130,6 @@ define Device/8dev_habanero-dvk
DEVICE_MODEL := Habanero DVK
IMAGE_SIZE := 30976k
SOC := qcom-ipq4019
- DEVICE_PACKAGES := ipq-wifi-8dev_habanero-dvk
IMAGE/sysupgrade.bin := append-kernel | pad-to 64k | append-rootfs | pad-rootfs | check-size | append-metadata
endef
TARGET_DEVICES += 8dev_habanero-dvk
@@ -169,7 +168,6 @@ define Device/aruba_glenmorangie
$(call Device/FitImageLzma)
DEVICE_VENDOR := Aruba
SOC := qcom-ipq4029
- DEVICE_PACKAGES := ipq-wifi-aruba_ap-303
endef
define Device/aruba_ap-303
@@ -225,7 +223,7 @@ define Device/asus_rt-ac42u
# Rather, this device is a/k/a RT-AC42U
# But we'll go with what the vendor firmware has...
UIMAGE_NAME:=$(shell echo -e '\03\01\01\01RT-AC82U')
- DEVICE_PACKAGES := ath10k-firmware-qca9984-ct ipq-wifi-asus_rt-ac42u kmod-usb-ledtrig-usbport
+ DEVICE_PACKAGES := ath10k-firmware-qca9984-ct kmod-usb-ledtrig-usbport
endef
TARGET_DEVICES += asus_rt-ac42u
@@ -283,7 +281,7 @@ define Device/avm_fritzrepeater-1200
DEVICE_VENDOR := AVM
DEVICE_MODEL := FRITZ!Repeater 1200
SOC := qcom-ipq4019
- DEVICE_PACKAGES := fritz-caldata fritz-tffs-nand ipq-wifi-avm_fritzrepeater-1200
+ DEVICE_PACKAGES := fritz-caldata fritz-tffs-nand
endef
TARGET_DEVICES += avm_fritzrepeater-1200
@@ -302,7 +300,7 @@ define Device/buffalo_wtr-m2133hp
DEVICE_VENDOR := Buffalo
DEVICE_MODEL := WTR-M2133HP
SOC := qcom-ipq4019
- DEVICE_PACKAGES := ath10k-firmware-qca9984-ct ipq-wifi-buffalo_wtr-m2133hp
+ DEVICE_PACKAGES := ath10k-firmware-qca9984-ct
BLOCKSIZE := 128k
PAGESIZE := 2048
endef
@@ -326,7 +324,7 @@ define Device/cellc_rtl30vw
IMAGE_SIZE := 57344k
BLOCKSIZE := 128k
PAGESIZE := 2048
- DEVICE_PACKAGES := kmod-usb-net-qmi-wwan kmod-usb-serial-option uqmi ipq-wifi-cellc_rtl30vw
+ DEVICE_PACKAGES := kmod-usb-net-qmi-wwan kmod-usb-serial-option uqmi
endef
TARGET_DEVICES += cellc_rtl30vw
@@ -412,7 +410,6 @@ define Device/dlink_dap-2610
# append-rootfs must start on an erase block boundary.
IMAGE/factory.bin := append-kernel | pad-offset 6144k 160 | append-rootfs | wrgg-image | check-size
IMAGE/sysupgrade.bin := append-kernel | wrgg-image | pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | check-size | append-metadata
- DEVICE_PACKAGES := ipq-wifi-dlink_dap2610
endef
TARGET_DEVICES += dlink_dap-2610
@@ -464,7 +461,7 @@ define Device/engenius_eap2200
SOC := qcom-ipq4019
BLOCKSIZE := 128k
PAGESIZE := 2048
- DEVICE_PACKAGES := ath10k-firmware-qca9888-ct ipq-wifi-engenius_eap2200 -kmod-ath10k-ct kmod-ath10k-ct-smallbuffers
+ DEVICE_PACKAGES := ath10k-firmware-qca9888-ct -kmod-ath10k-ct kmod-ath10k-ct-smallbuffers
endef
TARGET_DEVICES += engenius_eap2200
@@ -478,7 +475,6 @@ define Device/engenius_emd1
IMAGES += factory.bin
IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
IMAGE/factory.bin := qsdk-ipq-factory-nor | check-size
- DEVICE_PACKAGES := ipq-wifi-engenius_emd1
endef
TARGET_DEVICES += engenius_emd1
@@ -493,7 +489,6 @@ define Device/engenius_emr3500
IMAGES += factory.bin
IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
IMAGE/factory.bin := qsdk-ipq-factory-nor | check-size
- DEVICE_PACKAGES := ipq-wifi-engenius_emr3500
DEFAULT := n
endef
TARGET_DEVICES += engenius_emr3500
@@ -534,8 +529,7 @@ define Device/ezviz_cs-w3-wd1200g-eup
SOC := qcom-ipq4018
IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | \
append-metadata
- DEVICE_PACKAGES := -kmod-ath10k-ct kmod-ath10k-ct-smallbuffers \
- ipq-wifi-ezviz_cs-w3-wd1200g-eup
+ DEVICE_PACKAGES := -kmod-ath10k-ct kmod-ath10k-ct-smallbuffers
DEVICE_COMPAT_VERSION := 2.0
DEVICE_COMPAT_MESSAGE := uboot's bootcmd has to be updated (see wiki). \
Upgrade via sysupgrade mechanism is not possible.
@@ -664,7 +658,7 @@ define Device/linksys_mr8300
UBINIZE_OPTS := -E 5 # EOD marks to "hide" factory sig at EOF
IMAGES += factory.bin
IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi | linksys-image type=MR8300
- DEVICE_PACKAGES := ath10k-firmware-qca9888-ct ipq-wifi-linksys_mr8300-v0 kmod-usb-ledtrig-usbport
+ DEVICE_PACKAGES := ath10k-firmware-qca9888-ct kmod-usb-ledtrig-usbport
endef
TARGET_DEVICES += linksys_mr8300
@@ -673,7 +667,7 @@ define Device/luma_wrtq-329acn
DEVICE_VENDOR := Luma Home
DEVICE_MODEL := WRTQ-329ACN
SOC := qcom-ipq4018
- DEVICE_PACKAGES := ipq-wifi-luma_wrtq-329acn kmod-ath3k kmod-eeprom-at24 kmod-i2c-gpio
+ DEVICE_PACKAGES := kmod-ath3k kmod-eeprom-at24 kmod-i2c-gpio
IMAGE_SIZE := 76632k
BLOCKSIZE := 128k
PAGESIZE := 2048
@@ -699,7 +693,7 @@ define Device/mobipromo_cm520-79f
SOC := qcom-ipq4019
BLOCKSIZE := 128k
PAGESIZE := 2048
- DEVICE_PACKAGES := ipq-wifi-mobipromo_cm520-79f kmod-usb-ledtrig-usbport
+ DEVICE_PACKAGES := kmod-usb-ledtrig-usbport
endef
TARGET_DEVICES += mobipromo_cm520-79f
@@ -869,7 +863,6 @@ define Device/plasmacloud_pa1200
IMAGES += factory.bin
IMAGE/factory.bin := append-rootfs | pad-rootfs | openmesh-image ce_type=PA1200
IMAGE/sysupgrade.bin/squashfs := append-rootfs | pad-rootfs | sysupgrade-tar rootfs=$$$$@ | append-metadata
- DEVICE_PACKAGES := ipq-wifi-plasmacloud_pa1200
endef
TARGET_DEVICES += plasmacloud_pa1200
@@ -885,7 +878,7 @@ define Device/plasmacloud_pa2200
IMAGES += factory.bin
IMAGE/factory.bin := append-rootfs | pad-rootfs | openmesh-image ce_type=PA2200
IMAGE/sysupgrade.bin/squashfs := append-rootfs | pad-rootfs | sysupgrade-tar rootfs=$$$$@ | append-metadata
- DEVICE_PACKAGES := ath10k-firmware-qca9888-ct ipq-wifi-plasmacloud_pa2200
+ DEVICE_PACKAGES := ath10k-firmware-qca9888-ct
endef
TARGET_DEVICES += plasmacloud_pa2200
@@ -1003,7 +996,7 @@ define Device/zte_mf286d
BLOCKSIZE := 128k
PAGESIZE := 2048
KERNEL_IN_UBI := 1
- DEVICE_PACKAGES := ipq-wifi-zte_mf286d kmod-usb-net-qmi-wwan kmod-usb-serial-option uqmi
+ DEVICE_PACKAGES := kmod-usb-net-qmi-wwan kmod-usb-serial-option uqmi
endef
TARGET_DEVICES += zte_mf286d