aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx/image/generic.mk
diff options
context:
space:
mode:
authorTomasz Maciej Nowak <tmn505@gmail.com>2022-09-06 15:32:33 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2022-09-07 21:21:38 +0200
commit80baffd2aa91a1e95f818e7e9f7d668d3b64ed42 (patch)
tree5734228ce50df7b5dd50479f770f451911d71df6 /target/linux/ipq40xx/image/generic.mk
parent3b7948474f73b356a6d99b95f17aae93235f298d (diff)
downloadupstream-80baffd2aa91a1e95f818e7e9f7d668d3b64ed42.tar.gz
upstream-80baffd2aa91a1e95f818e7e9f7d668d3b64ed42.tar.bz2
upstream-80baffd2aa91a1e95f818e7e9f7d668d3b64ed42.zip
ipq40xx: add support for Pakedge WR-1
Pakedge WR-1 is a dual-band wireless router. Specification SoC: Qualcomm Atheros IPQ4018 RAM: 256 MB DDR3 Flash: 32 MB SPI NOR WIFI: 2.4 GHz 2T2R integrated 5 GHz 2T2R integrated Ethernet: 5x 10/100/1000 Mbps QCA8075 USB: 1x 2.0 LEDS: 8x (3 GPIO controlled, 5 connected to switch) Buttons: 1x GPIO controlled UART: pin header J5 1. 3.3V, 2. GND, 3. TX, 4. RX baud: 115200, parity: none, flow control: none Installation 1. Rename initramfs image to: openwrt-ipq806x-qcom-ipq40xx-ap.dk01.1-c1-fit-uImage-initramfs.itb and copy it to USB flash drive with FAT32 file system. 2. Connect USB flash drive to the router and apply power while pressing reset button. Hold the button, on the lates bootloader version, when Power and WiFi-5 LEDs will start blinking release it. For the older bootloader holding it for 15 seconds should suffice. 3. Now the router boots the initramfs image, at some point (close to one minute) the Power LED will start blinking, when stops, router is fully booted. 4. Connect to one of LAN ports and use SSH to open the shell at 192.168.1.1. 5. ATTENTION! now backup the mtd8 and mtd9 partitions, it's necessary if, at some point, You want to go back to original firmware. The firmware provided by manufacturer on its site is encrypted and U-Boot accepts only decrypted factory images, so there's no way to restore original firmware. 6. If the backup is prepared, transfer the sysupgrade image to the router and use 'sysupgrade' command to flash it. 7. After successful flashing router will reboot. At some point the Power LED will start blinking, wait till it stops, then router is ready for configuration. Additional information U-Boot command line is password protected. Password is unknown. Signed-off-by: Tomasz Maciej Nowak <tmn505@gmail.com>
Diffstat (limited to 'target/linux/ipq40xx/image/generic.mk')
-rw-r--r--target/linux/ipq40xx/image/generic.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/ipq40xx/image/generic.mk b/target/linux/ipq40xx/image/generic.mk
index e8f8fa27b9..5652bf9414 100644
--- a/target/linux/ipq40xx/image/generic.mk
+++ b/target/linux/ipq40xx/image/generic.mk
@@ -894,6 +894,18 @@ define Device/p2w_r619ac-128m
endef
TARGET_DEVICES += p2w_r619ac-128m
+define Device/pakedge_wr-1
+ $(call Device/FitImageLzma)
+ DEVICE_VENDOR := Pakedge
+ DEVICE_MODEL := WR-1
+ DEVICE_DTS_CONFIG := config@ap.dk01.1-c1
+ SOC := qcom-ipq4018
+ BLOCKSIZE := 64k
+ IMAGE_SIZE := 31232k
+ IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | append-metadata
+endef
+TARGET_DEVICES += pakedge_wr-1
+
define Device/plasmacloud_pa1200
$(call Device/FitImageLzma)
DEVICE_VENDOR := Plasma Cloud