aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx/image/generic.mk
diff options
context:
space:
mode:
authorNicholas Smith <nicholas@nbembedded.com>2022-03-11 13:54:07 +1000
committerHauke Mehrtens <hauke@hauke-m.de>2022-03-19 20:05:00 +0100
commit7ea2f3d6e22b506d137cf255ae73ae498c176d1c (patch)
treeea7b28457127d9abdb88c6257582ca2291680b39 /target/linux/ipq40xx/image/generic.mk
parent42626aef676d2ca1ea1577b7a47ba8e4135f1a4c (diff)
downloadupstream-7ea2f3d6e22b506d137cf255ae73ae498c176d1c.tar.gz
upstream-7ea2f3d6e22b506d137cf255ae73ae498c176d1c.tar.bz2
upstream-7ea2f3d6e22b506d137cf255ae73ae498c176d1c.zip
ipq40xx: add support for Telco X1 Pro
Telco X1 Pro is a Cat12 LTE-A Pro modem router. Vendor firmware is based on a recent version of OpenWrt. Flashing is possible via CLI using sysupgrade -F -n The serial headers allow bootloader and console access Serial setting: 115200 8N1 Brief Specifications: IPQ4019 SoC 32MB flash 512MB RAM 4x gigabit LAN 1x gigabit WAN Dual-band Wave-2 wifi 2x SMA LTE antenna connectors 2x RP-SMA wifi antennas 1x USB 2.0 port 1x Reset button Serial headers installed 1x Nano SIM tray 1x Quectel EM-12G LTE-A Pro modem 1x M.2 slot attached to USB 3.0 1x internal micro SD card slot Signed-off-by: Nicholas Smith <nicholas@nbembedded.com>
Diffstat (limited to 'target/linux/ipq40xx/image/generic.mk')
-rw-r--r--target/linux/ipq40xx/image/generic.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/ipq40xx/image/generic.mk b/target/linux/ipq40xx/image/generic.mk
index 15e9a24544..60a76bc150 100644
--- a/target/linux/ipq40xx/image/generic.mk
+++ b/target/linux/ipq40xx/image/generic.mk
@@ -963,6 +963,18 @@ define Device/teltonika_rutx10
endef
TARGET_DEVICES += teltonika_rutx10
+define Device/tel_x1pro
+ $(call Device/FitImage)
+ DEVICE_VENDOR := Telco
+ DEVICE_MODEL := X1 Pro
+ SOC := qcom-ipq4019
+ KERNEL_SIZE := 4096k
+ IMAGE_SIZE := 31232k
+ IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
+ DEVICE_PACKAGES := kmod-usb-net-qmi-wwan kmod-usb-serial-option uqmi
+endef
+TARGET_DEVICES += tel_x1pro
+
define Device/unielec_u4019-32m
$(call Device/FitImage)
DEVICE_VENDOR := Unielec