aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx/image/generic.mk
diff options
context:
space:
mode:
authorTony Ambardar <itugrok@yahoo.com>2022-12-05 19:44:32 -0800
committerTony Ambardar <itugrok@yahoo.com>2022-12-31 05:02:38 -0800
commit2a9f3b7717d081a9d6cb34d7ad04e14b4e50d69e (patch)
tree4d47f78f17dee7a4d6f1ef2b64fabe627a1979e5 /target/linux/ipq40xx/image/generic.mk
parentcda6f1c832f96bd24e5398e156a0e8d639c691a0 (diff)
downloadupstream-2a9f3b7717d081a9d6cb34d7ad04e14b4e50d69e.tar.gz
upstream-2a9f3b7717d081a9d6cb34d7ad04e14b4e50d69e.tar.bz2
upstream-2a9f3b7717d081a9d6cb34d7ad04e14b4e50d69e.zip
ipq40xx: fix up Linksys WHW01 board name, device definition
Update the board name defined in DTS to match online documentation and the name encoded into factory firmware. This helps supports flashing firmware factory images using 'sysupgrade'. Original WHW01 device definition assumes the rootfs IMAGE_SIZE is 33 MB instead of the correct 74 MB, and defines factory images which include extra adjustments/padding that do not match OEM factory images and may cause problems flashing. Update image size and build recipe to fix these. Suggested-by: Wyatt Martin <wawowl@gmail.com> Signed-off-by: Tony Ambardar <itugrok@yahoo.com>
Diffstat (limited to 'target/linux/ipq40xx/image/generic.mk')
-rw-r--r--target/linux/ipq40xx/image/generic.mk11
1 files changed, 4 insertions, 7 deletions
diff --git a/target/linux/ipq40xx/image/generic.mk b/target/linux/ipq40xx/image/generic.mk
index e17db37d82..a2807c6c9c 100644
--- a/target/linux/ipq40xx/image/generic.mk
+++ b/target/linux/ipq40xx/image/generic.mk
@@ -720,25 +720,22 @@ define Device/linksys_mr8300
endef
TARGET_DEVICES += linksys_mr8300
-define Device/linksys_whw01-v1
+define Device/linksys_whw01
$(call Device/FitzImage)
DEVICE_VENDOR := Linksys
DEVICE_MODEL := WHW01
- DEVICE_VARIANT := v1
KERNEL_SIZE := 6144k
- IMAGE_SIZE := 28704512 # 28032k minus linksys signature (256-bytes).
+ IMAGE_SIZE := 75776K
SOC := qcom-ipq4018
BLOCKSIZE := 128k
PAGESIZE := 2048
UBINIZE_OPTS := -E 5 # EOD marks to "hide" factory sig at EOF
IMAGES += factory.bin
- IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | \
- append-ubi | linksys-image type=WHW01 | pad-to $$$$(PAGESIZE) | \
- check-size
+ IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi | linksys-image type=WHW01
DEVICE_PACKAGES := uboot-envtools kmod-leds-pca963x
endef
# Missing DSA Setup
-#TARGET_DEVICES += linksys_whw01-v1
+#TARGET_DEVICES += linksys_whw01
define Device/luma_wrtq-329acn
$(call Device/FitImage)