aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx/image/chromium.mk
diff options
context:
space:
mode:
authorTomasz Maciej Nowak <tmn505@gmail.com>2022-08-25 20:26:11 +0200
committerDavid Bauer <mail@david-bauer.net>2022-09-06 02:50:04 +0200
commit4d8b42d8a7774070ac0439915f8de1430db9a8e3 (patch)
treef75f6026bec5cfbc6db7aa4148ace1b08e9628c1 /target/linux/ipq40xx/image/chromium.mk
parentee035de0fd4cf674dccc455cdb10dfa414f378c7 (diff)
downloadupstream-4d8b42d8a7774070ac0439915f8de1430db9a8e3.tar.gz
upstream-4d8b42d8a7774070ac0439915f8de1430db9a8e3.tar.bz2
upstream-4d8b42d8a7774070ac0439915f8de1430db9a8e3.zip
ipq40xx: point to externally compiled dtbs in recipes
Adjusting dts will cause a rebuild of whole kernel as the buildroot considers this a part of kernel source. It's a royal PITA when trying to prepare support for new device, since this takes a lot of time on slower systems. As it stands, buildroot itself, with own rule, also compiles dtbs and the results are $(KDIR)/image-$(DEVICE_DTS).dtb. With setting DEVICE_DTS_DIR to directory holding the device dts (similarly to some other targets), buildroot doesn't consider changed dts as part of kernel source and rebuilds only dtb. This really speeds up development. And since the kernel built dts are no longer used, drop the paches adding dtses to its build. Signed-off-by: Tomasz Maciej Nowak <tmn505@gmail.com> Reviewed-by: Robert Marko <robimarko@gmail.com>
Diffstat (limited to 'target/linux/ipq40xx/image/chromium.mk')
-rw-r--r--target/linux/ipq40xx/image/chromium.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ipq40xx/image/chromium.mk b/target/linux/ipq40xx/image/chromium.mk
index 567a5e7ca5..2abd2df02a 100644
--- a/target/linux/ipq40xx/image/chromium.mk
+++ b/target/linux/ipq40xx/image/chromium.mk
@@ -26,7 +26,7 @@ define Device/google_wifi
DEVICE_MODEL := WiFi (Gale)
SOC := qcom-ipq4019
KERNEL_SUFFIX := -fit-zImage.itb.vboot
- KERNEL = kernel-bin | fit none $$(DTS_DIR)/$$(DEVICE_DTS).dtb | cros-vboot
+ KERNEL = kernel-bin | fit none $$(KDIR)/image-$$(DEVICE_DTS).dtb | cros-vboot
KERNEL_NAME := zImage
IMAGES += factory.bin
IMAGE/factory.bin := cros-gpt | append-kernel-part | append-rootfs