aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx/files
diff options
context:
space:
mode:
authorTony Ambardar <itugrok@yahoo.com>2022-11-30 20:10:59 -0800
committerTony Ambardar <itugrok@yahoo.com>2022-12-31 05:02:38 -0800
commitcda6f1c832f96bd24e5398e156a0e8d639c691a0 (patch)
tree68f6837653aec842b08f45b2e3c5c2286046403b /target/linux/ipq40xx/files
parentaf3c9b74e177019b18055c263099a42c1c6c3453 (diff)
downloadupstream-cda6f1c832f96bd24e5398e156a0e8d639c691a0.tar.gz
upstream-cda6f1c832f96bd24e5398e156a0e8d639c691a0.tar.bz2
upstream-cda6f1c832f96bd24e5398e156a0e8d639c691a0.zip
ipq40xx: re-enable EA6350v3, EA8300, MR8300 builds
Raise the kernel size from 3 MB to 5 MB for EA6350v3, EA8300 and MR8300, and correspondingly reduce the rootfs size by 2 MB: * modify partition definitions in related .dts files * modify device kernel/image sizes in generic.mk Update to compat-version 2.0 to force factory image usage on sysupgrade, noting the current version 1.1 is an unreleased update for DSA migration. Also update the compat-version message, explaining the need to run one of the following console commands to update U-Boot's kernel-size variable before flashing the OpenWrt factory image. fw_setenv kernsize 500000 # (OpenWrt command line) setenv kernsize 500000 ; saveenv # (U-Boot serial console) Finally, re-enable the 3 devices. Reviewed-by: Robert Marko <robimarko@gmail.com> Tested-by: Nicolas TORMO <badulesia.granieri@gmail.com> # MR8300 Tested-by: Tony Ambardar <itugrok@yahoo.com> # EA6350v3 Signed-off-by: Tony Ambardar <itugrok@yahoo.com>
Diffstat (limited to 'target/linux/ipq40xx/files')
-rw-r--r--target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-ea6350v3.dts8
-rw-r--r--target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4019-xx8300.dtsi8
2 files changed, 8 insertions, 8 deletions
diff --git a/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-ea6350v3.dts b/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-ea6350v3.dts
index 75b556a7f9..cd5b4c6ccc 100644
--- a/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-ea6350v3.dts
+++ b/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-ea6350v3.dts
@@ -269,17 +269,17 @@
label = "kernel";
reg = <0x00000000 0x02800000>;
};
- rootfs@300000 {
+ rootfs@500000 {
label = "rootfs";
- reg = <0x00300000 0x02500000>;
+ reg = <0x00500000 0x02300000>;
};
alt_kernel@2800000 {
label = "alt_kernel";
reg = <0x02800000 0x02800000>;
};
- alt_rootfs@2b00000 {
+ alt_rootfs@2d00000 {
label = "alt_rootfs";
- reg = <0x02b00000 0x02500000>;
+ reg = <0x02d00000 0x02300000>;
};
sysdiag@5000000 {
label = "sysdiag";
diff --git a/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4019-xx8300.dtsi b/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4019-xx8300.dtsi
index 4f2cf1f516..51a37290a0 100644
--- a/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4019-xx8300.dtsi
+++ b/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4019-xx8300.dtsi
@@ -195,9 +195,9 @@
reg = <0x780000 0x5800000>;
};
- partition@a80000 {
+ partition@c80000 {
label = "rootfs";
- reg = <0xa80000 0x5500000>;
+ reg = <0xc80000 0x5300000>;
};
partition@5f80000 {
@@ -205,9 +205,9 @@
reg = <0x5f80000 0x5800000>;
};
- partition@6280000 {
+ partition@6480000 {
label = "alt_rootfs";
- reg = <0x6280000 0x5500000>;
+ reg = <0x6480000 0x5300000>;
};
partition@b780000 {