aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx/Makefile
diff options
context:
space:
mode:
authorJohn Thomson <git@johnthomson.fastmail.com.au>2022-05-21 08:13:21 +1000
committerHauke Mehrtens <hauke@hauke-m.de>2022-05-27 14:15:09 +0200
commit602b5f6c60a2827bd918dfae0ffb271f8b88f4df (patch)
tree35d3f063d5ec4f780c939b8de27b3f0d3c133cf5 /target/linux/ipq40xx/Makefile
parentf84b525a84855532ce520139730c3bdd2baf21d0 (diff)
downloadupstream-602b5f6c60a2827bd918dfae0ffb271f8b88f4df.tar.gz
upstream-602b5f6c60a2827bd918dfae0ffb271f8b88f4df.tar.bz2
upstream-602b5f6c60a2827bd918dfae0ffb271f8b88f4df.zip
ipq40xx: cut ath10k board file for mikrotik subtarget
Avoid shipping ath10k board file in Mikrotik initram images Most will only ever need to use these initram images onceā€”to initially load OpenWrt, but fix these images for more consistent Wi-Fi performance between the initram and installed squashfs images. OpenWrt BUILDBOT config ignores -cut packages in the initram images build. This results in BUILDBOT initram images including the linux-firmware qca4019 board-2.bin, and (initram image booted) Mikrotik devices loading a generic BDF, rather than the intended BDF data loaded from NOR as an api 1 board_file. buildbot snapshot booted as initram image: cat /etc/openwrt_version r19679-810eac8c7f dmesg | grep ath10k | grep -E board\|BDF [ 9.794556] ath10k_ahb a000000.wifi: Loading BDF type 0 [ 9.807192] ath10k_ahb a000000.wifi: board_file api 2 bmi_id 0:16 crc32 11892f9b [ 12.457105] ath10k_ahb a800000.wifi: Loading BDF type 0 [ 12.464945] ath10k_ahb a800000.wifi: board_file api 2 bmi_id 0:17 crc32 11892f9b CC: Robert Marko <robimarko@gmail.com> Fixes: 5eee67a72fed ("ipq40xx: mikrotik: dont include ath10k-board-qca4019 by default") Signed-off-by: John Thomson <git@johnthomson.fastmail.com.au> Reviewed-by: Robert Marko <robimarko@gmail.com>
Diffstat (limited to 'target/linux/ipq40xx/Makefile')
-rw-r--r--target/linux/ipq40xx/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ipq40xx/Makefile b/target/linux/ipq40xx/Makefile
index 7df920e2d8..19b63cdd65 100644
--- a/target/linux/ipq40xx/Makefile
+++ b/target/linux/ipq40xx/Makefile
@@ -19,6 +19,6 @@ DEFAULT_PACKAGES += \
kmod-leds-gpio kmod-gpio-button-hotplug swconfig \
kmod-ath10k-ct wpad-basic-wolfssl \
kmod-usb3 kmod-usb-dwc3 ath10k-firmware-qca4019-ct \
- ath10k-board-qca4019 uboot-envtools
+ uboot-envtools
$(eval $(call BuildTarget))