aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq40xx/Makefile
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2019-01-03 23:24:16 +0100
committerChristian Lamparter <chunkeey@gmail.com>2019-01-05 22:23:10 +0100
commit32e953b821fabcd5b88f53347bd92ccc7782e127 (patch)
tree8dec62602d56ab5b4a86f37a5635e27a3aa9d2da /target/linux/ipq40xx/Makefile
parent3801f8a7f780b00c06a22d531c56e49a11863043 (diff)
downloadupstream-32e953b821fabcd5b88f53347bd92ccc7782e127.tar.gz
upstream-32e953b821fabcd5b88f53347bd92ccc7782e127.tar.bz2
upstream-32e953b821fabcd5b88f53347bd92ccc7782e127.zip
ipq40xx: fix 4.14 ImageBuilder build woes
Robert Marko reported an issue with the current imagebuilder images: "Imagebuilder includes the new kmod-usb-dwc3-qcom USB driver package by default even on 4.14. [...] the current state imagebuilder can't build images under 4.14 at all as the kmod-usb-dwc3-qcom does not exist in it so it throws and error and exits." This patch reverts the Makefile to just kmod-usb-dwc3-of-simple and once the switch to 4.19 is done. It also removes the kmod-usb-phy-qcom-dwc3 as they only contain the usb-phy drivers for the ipq806x generation. Dynamic switching based on the KERNEL_PATCHVER is possible by using: $(if $(filter 4.14,$(KERNEL_PATCHVER)),kmod-usb-dwc3-of-simple,kmod-usb-dwc3-qcom) though it Fixes: 13321fa1429 ("ipq40xx: Use kmod-usb-dwc3-qcom by default") Fixes: 6e58fb2c33e ("ipq40xx: kmod-usb-dwc3-of-simple vs kmod-usb-dwc3-qcom") Reported-by: Robert Marko <robimarko@gmail.com> Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target/linux/ipq40xx/Makefile')
-rw-r--r--target/linux/ipq40xx/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/ipq40xx/Makefile b/target/linux/ipq40xx/Makefile
index 4813ad2425..ab7b174e40 100644
--- a/target/linux/ipq40xx/Makefile
+++ b/target/linux/ipq40xx/Makefile
@@ -15,9 +15,9 @@ KERNELNAME:=zImage Image dtbs
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += \
+ kmod-usb-dwc3-of-simple \
kmod-leds-gpio kmod-gpio-button-hotplug swconfig \
kmod-ath10k-ct wpad-basic \
- kmod-usb3 kmod-usb-dwc3-of-simple kmod-usb-phy-qcom-dwc3 \
- kmod-usb-dwc3-qcom ath10k-firmware-qca4019-ct
+ kmod-usb3 kmod-usb-dwc3 ath10k-firmware-qca4019-ct
$(eval $(call BuildTarget))