aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/imx
diff options
context:
space:
mode:
authorKuan-Yi Li <kyli@abysm.org>2022-10-20 11:31:19 +0800
committerÁlvaro Fernández Rojas <noltari@gmail.com>2022-11-15 20:49:58 +0100
commita110418027a4c6f97c33980b8e4d7f07d39726de (patch)
treedcffd8755b831d6ec1551bf467af71aa6dfd918c /target/linux/imx
parent729cdff71dc00f6432fcd3d5045c610d8ff27ed9 (diff)
downloadupstream-a110418027a4c6f97c33980b8e4d7f07d39726de.tar.gz
upstream-a110418027a4c6f97c33980b8e4d7f07d39726de.tar.bz2
upstream-a110418027a4c6f97c33980b8e4d7f07d39726de.zip
linux-firmware: offer two versions of firmware for CYW4339
According to commit 6f6c2fb321, AP6335 module used in PICO-PI-IMX7D works only with firmware from `linux-firmware`. However, firmware from `cypress-firmware` suite is directly from the chip company (Infineon) and is actually newer. Instead of dropping the firmware from Infineon, create a package named `brcmfmac-firmware-4339-sdio`, and keep the Infineon version of `cypress-firmware-4339-sdio` around. This gives us devs the option to choose. Also, it means that - packages `brcmfmac-firmware-*` uniformly come from `linux-firmware` - packages `cypress-firmware-*` uniformly come from `cypress-firmware` so hopefully brings more clarity. Tested-by: Lech Perczak <lech.perczak@gmail.com> Signed-off-by: Kuan-Yi Li <kyli@abysm.org>
Diffstat (limited to 'target/linux/imx')
-rw-r--r--target/linux/imx/image/cortexa7.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/imx/image/cortexa7.mk b/target/linux/imx/image/cortexa7.mk
index b4ac1b6904..6306ed421d 100644
--- a/target/linux/imx/image/cortexa7.mk
+++ b/target/linux/imx/image/cortexa7.mk
@@ -21,7 +21,7 @@ define Device/technexion_imx7d-pico-pi
DEVICE_PACKAGES := kmod-sound-core kmod-sound-soc-imx kmod-sound-soc-imx-sgtl5000 \
kmod-can kmod-can-flexcan kmod-can-raw kmod-leds-gpio \
kmod-input-touchscreen-edt-ft5x06 kmod-usb-hid kmod-btsdio \
- kmod-brcmfmac cypress-firmware-4339-sdio cypress-nvram-4339-pico-pi-imx7d
+ kmod-brcmfmac brcmfmac-firmware-4339-sdio cypress-nvram-4339-pico-pi-imx7d
FILESYSTEMS := squashfs
IMAGES := combined.bin sysupgrade.bin
IMAGE/combined.bin := append-rootfs | pad-extra 128k | imx-sdcard-raw-uboot