aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/imx6
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2019-06-12 01:14:25 +0200
committerDaniel Golle <daniel@makrotopia.org>2019-06-12 01:18:52 +0200
commit000d400baa0af2e42c9a462e42df7dc9abde1ec7 (patch)
treea11c2dd570e8f02c4a141f135fc8db1e1d391ef2 /target/linux/imx6
parentc4e727f01cc40bd57274d0b885b0f75cde9c4683 (diff)
downloadupstream-000d400baa0af2e42c9a462e42df7dc9abde1ec7.tar.gz
upstream-000d400baa0af2e42c9a462e42df7dc9abde1ec7.tar.bz2
upstream-000d400baa0af2e42c9a462e42df7dc9abde1ec7.zip
kernel: drop everything not on kernel version 4.14
* Remove testing patches for kernel version 4.19 * remove targets ar7, ixp4xx, orion Those targets are still on kernel 4.9, patches for 4.14 were not ready in time. They may be readded once people prepare and test patches for kernel 4.14. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'target/linux/imx6')
-rw-r--r--target/linux/imx6/Makefile1
-rw-r--r--target/linux/imx6/patches-4.19/100-bootargs.patch11
-rw-r--r--target/linux/imx6/patches-4.19/301-apalis-ixora-dts-leds.patch86
-rw-r--r--target/linux/imx6/patches-4.19/302-apalis-ixora-dts-reset-button.patch76
4 files changed, 0 insertions, 174 deletions
diff --git a/target/linux/imx6/Makefile b/target/linux/imx6/Makefile
index 457e767c05..49e4487026 100644
--- a/target/linux/imx6/Makefile
+++ b/target/linux/imx6/Makefile
@@ -15,7 +15,6 @@ CPU_SUBTYPE:=neon
MAINTAINER:=Luka Perkov <luka@openwrt.org>
KERNEL_PATCHVER:=4.14
-KERNEL_TESTING_PATCHVER := 4.19
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/imx6/patches-4.19/100-bootargs.patch b/target/linux/imx6/patches-4.19/100-bootargs.patch
deleted file mode 100644
index caf2d2a372..0000000000
--- a/target/linux/imx6/patches-4.19/100-bootargs.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/arch/arm/boot/dts/imx6dl-wandboard.dts
-+++ b/arch/arm/boot/dts/imx6dl-wandboard.dts
-@@ -15,4 +15,8 @@
- memory@10000000 {
- reg = <0x10000000 0x40000000>;
- };
-+
-+ chosen {
-+ bootargs = "console=ttymxc0,115200";
-+ };
- };
diff --git a/target/linux/imx6/patches-4.19/301-apalis-ixora-dts-leds.patch b/target/linux/imx6/patches-4.19/301-apalis-ixora-dts-leds.patch
deleted file mode 100644
index bae9df1734..0000000000
--- a/target/linux/imx6/patches-4.19/301-apalis-ixora-dts-leds.patch
+++ /dev/null
@@ -1,86 +0,0 @@
-arm: dts: apalis-ixora: Add status LEDs aliases
-
-Signed-off-by: Petr Štetiar <ynezz@true.cz>
-
---- a/arch/arm/boot/dts/imx6q-apalis-ixora.dts
-+++ b/arch/arm/boot/dts/imx6q-apalis-ixora.dts
-@@ -60,6 +60,10 @@
- i2c2 = &i2c2;
- rtc0 = &rtc_i2c;
- rtc1 = &snvs_rtc;
-+ led-boot = &led_boot;
-+ led-failsafe = &led_failsafe;
-+ led-running = &led_running;
-+ led-upgrade = &led_upgrade;
- };
-
- chosen {
-@@ -127,22 +131,22 @@
- pinctrl-names = "default";
- pinctrl-0 = <&pinctrl_leds_ixora>;
-
-- led4-green {
-+ led_running: led4-green {
- label = "LED_4_GREEN";
- gpios = <&gpio1 17 GPIO_ACTIVE_HIGH>;
- };
-
-- led4-red {
-+ led_upgrade: led4-red {
- label = "LED_4_RED";
- gpios = <&gpio1 21 GPIO_ACTIVE_HIGH>;
- };
-
-- led5-green {
-+ led_boot: led5-green {
- label = "LED_5_GREEN";
- gpios = <&gpio2 1 GPIO_ACTIVE_HIGH>;
- };
-
-- led5-red {
-+ led_failsafe: led5-red {
- label = "LED_5_RED";
- gpios = <&gpio2 2 GPIO_ACTIVE_HIGH>;
- };
---- a/arch/arm/boot/dts/imx6q-apalis-ixora-v1.1.dts
-+++ b/arch/arm/boot/dts/imx6q-apalis-ixora-v1.1.dts
-@@ -61,6 +61,10 @@
- i2c2 = &i2c2;
- rtc0 = &rtc_i2c;
- rtc1 = &snvs_rtc;
-+ led-boot = &led_boot;
-+ led-failsafe = &led_failsafe;
-+ led-running = &led_running;
-+ led-upgrade = &led_upgrade;
- };
-
- chosen {
-@@ -128,22 +132,22 @@
- pinctrl-names = "default";
- pinctrl-0 = <&pinctrl_leds_ixora>;
-
-- led4-green {
-+ led_running: led4-green {
- label = "LED_4_GREEN";
-- gpios = <&gpio1 14 GPIO_ACTIVE_HIGH>;
-+ gpios = <&gpio1 17 GPIO_ACTIVE_HIGH>;
- };
-
-- led4-red {
-+ led_upgrade: led4-red {
- label = "LED_4_RED";
-- gpios = <&gpio1 12 GPIO_ACTIVE_HIGH>;
-+ gpios = <&gpio1 21 GPIO_ACTIVE_HIGH>;
- };
-
-- led5-green {
-+ led_boot: led5-green {
- label = "LED_5_GREEN";
- gpios = <&gpio2 1 GPIO_ACTIVE_HIGH>;
- };
-
-- led5-red {
-+ led_failsafe: led5-red {
- label = "LED_5_RED";
- gpios = <&gpio2 2 GPIO_ACTIVE_HIGH>;
- };
diff --git a/target/linux/imx6/patches-4.19/302-apalis-ixora-dts-reset-button.patch b/target/linux/imx6/patches-4.19/302-apalis-ixora-dts-reset-button.patch
deleted file mode 100644
index da9de296a2..0000000000
--- a/target/linux/imx6/patches-4.19/302-apalis-ixora-dts-reset-button.patch
+++ /dev/null
@@ -1,76 +0,0 @@
-arm: dts: apalis-ixora: Add switch3 as reset button
-
-Signed-off-by: Petr Štetiar <ynezz@true.cz>
-
---- a/arch/arm/boot/dts/imx6q-apalis-ixora-v1.1.dts
-+++ b/arch/arm/boot/dts/imx6q-apalis-ixora-v1.1.dts
-@@ -74,7 +74,7 @@
- gpio-keys {
- compatible = "gpio-keys";
- pinctrl-names = "default";
-- pinctrl-0 = <&pinctrl_gpio_keys>;
-+ pinctrl-0 = <&pinctrl_gpio_keys &pinctrl_switch3_ixora>;
-
- wakeup {
- label = "Wake-Up";
-@@ -83,6 +83,13 @@
- debounce-interval = <10>;
- wakeup-source;
- };
-+
-+ reset {
-+ label = "reset";
-+ gpios = <&gpio1 16 GPIO_ACTIVE_LOW>;
-+ linux,code = <KEY_RESTART>;
-+ debounce-interval = <10>;
-+ };
- };
-
- lcd_display: disp0 {
-@@ -296,4 +303,10 @@
- MX6QDL_PAD_NANDF_D2__GPIO2_IO02 0x1b0b0
- >;
- };
-+
-+ pinctrl_switch3_ixora: switch3ixora {
-+ fsl,pins = <
-+ MX6QDL_PAD_SD1_DAT0__GPIO1_IO16 0x1b0b0
-+ >;
-+ };
- };
---- a/arch/arm/boot/dts/imx6q-apalis-ixora.dts
-+++ b/arch/arm/boot/dts/imx6q-apalis-ixora.dts
-@@ -73,7 +73,7 @@
- gpio-keys {
- compatible = "gpio-keys";
- pinctrl-names = "default";
-- pinctrl-0 = <&pinctrl_gpio_keys>;
-+ pinctrl-0 = <&pinctrl_gpio_keys &pinctrl_switch3_ixora>;
-
- wakeup {
- label = "Wake-Up";
-@@ -82,6 +82,13 @@
- debounce-interval = <10>;
- wakeup-source;
- };
-+
-+ reset {
-+ label = "reset";
-+ gpios = <&gpio1 16 GPIO_ACTIVE_LOW>;
-+ linux,code = <KEY_RESTART>;
-+ debounce-interval = <10>;
-+ };
- };
-
- lcd_display: disp0 {
-@@ -297,4 +304,10 @@
- MX6QDL_PAD_NANDF_D2__GPIO2_IO02 0x1b0b0
- >;
- };
-+
-+ pinctrl_switch3_ixora: switch3ixora {
-+ fsl,pins = <
-+ MX6QDL_PAD_SD1_DAT0__GPIO1_IO16 0x1b0b0
-+ >;
-+ };
- };