aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/imx6
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-10 09:59:10 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-10 12:10:20 +0100
commit348fedc1a621117de10cc1f611ab96b19c777e53 (patch)
tree6c4749028e859a46729875a36b5d5b593738e0ac /target/linux/imx6
parentc524d1b256efd765491aa9b58d1ee947a954db96 (diff)
downloadupstream-348fedc1a621117de10cc1f611ab96b19c777e53.tar.gz
upstream-348fedc1a621117de10cc1f611ab96b19c777e53.tar.bz2
upstream-348fedc1a621117de10cc1f611ab96b19c777e53.zip
imx6: build support for the ventana ethernet expansion board into the kernel instead of packaging it
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/imx6')
-rw-r--r--target/linux/imx6/config-4.41
-rw-r--r--target/linux/imx6/image/Makefile2
2 files changed, 2 insertions, 1 deletions
diff --git a/target/linux/imx6/config-4.4 b/target/linux/imx6/config-4.4
index 44c0e99f3a..353ca2e6d8 100644
--- a/target/linux/imx6/config-4.4
+++ b/target/linux/imx6/config-4.4
@@ -144,6 +144,7 @@ CONFIG_FS_MBCACHE=y
CONFIG_FS_POSIX_ACL=y
CONFIG_FTRACE=y
# CONFIG_FTRACE_SYSCALLS is not set
+CONFIG_GATEWORKS_GW16083=y
CONFIG_GENERIC_ALLOCATOR=y
CONFIG_GENERIC_BUG=y
CONFIG_GENERIC_CLOCKEVENTS=y
diff --git a/target/linux/imx6/image/Makefile b/target/linux/imx6/image/Makefile
index 2c17058250..2e4763ea65 100644
--- a/target/linux/imx6/image/Makefile
+++ b/target/linux/imx6/image/Makefile
@@ -90,7 +90,7 @@ define Device/ventana
kmod-sound-core kmod-sound-soc-imx kmod-sound-soc-imx-sgtl5000 \
kmod-can kmod-can-flexcan kmod-can-raw \
kmod-hwmon-gsc \
- kmod-leds-gpio kmod-pps-gpio kmod-gw16083 \
+ kmod-leds-gpio kmod-pps-gpio \
kobs-ng
KERNEL += | boot-overlay
IMAGES := nand.ubi bootfs.tar.gz