aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/imx6
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-10 10:10:13 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-10 12:10:20 +0100
commit745069895775d1fbd8988a0825f24f6b503517b3 (patch)
tree763ad418aa3d04df53520a38f858b349db0689f8 /target/linux/imx6
parent7f0796d874f8cbcc1bd7705ff4edf8c30223d2bd (diff)
downloadupstream-745069895775d1fbd8988a0825f24f6b503517b3.tar.gz
upstream-745069895775d1fbd8988a0825f24f6b503517b3.tar.bz2
upstream-745069895775d1fbd8988a0825f24f6b503517b3.zip
imx6: enable the chipidea usb driver in the kernel config instead of packaging it
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/imx6')
-rw-r--r--target/linux/imx6/config-4.426
-rw-r--r--target/linux/imx6/image/Makefile4
-rw-r--r--target/linux/imx6/profiles/100-generic.mk2
3 files changed, 26 insertions, 6 deletions
diff --git a/target/linux/imx6/config-4.4 b/target/linux/imx6/config-4.4
index 353ca2e6d8..94be69bb6e 100644
--- a/target/linux/imx6/config-4.4
+++ b/target/linux/imx6/config-4.4
@@ -57,6 +57,7 @@ CONFIG_CLKSRC_OF=y
CONFIG_CLKSRC_PROBE=y
CONFIG_CLONE_BACKWARDS=y
CONFIG_COMMON_CLK=y
+CONFIG_CONFIGFS_FS=m
CONFIG_CPUFREQ_DT=y
CONFIG_CPU_32v6K=y
CONFIG_CPU_32v7=y
@@ -403,8 +404,31 @@ CONFIG_UBIFS_FS_ADVANCED_COMPR=y
CONFIG_UBIFS_FS_LZO=y
CONFIG_UBIFS_FS_ZLIB=y
CONFIG_UNCOMPRESS_INCLUDE="debug/uncompress.h"
-# CONFIG_USB_MXS_PHY is not set
+CONFIG_USB=y
+CONFIG_USB_CHIPIDEA=y
+# CONFIG_USB_CHIPIDEA_DEBUG is not set
+CONFIG_USB_CHIPIDEA_HOST=y
+CONFIG_USB_CHIPIDEA_OF=y
+CONFIG_USB_CHIPIDEA_UDC=y
+CONFIG_USB_COMMON=y
+CONFIG_USB_EHCI_HCD=y
+# CONFIG_USB_EHCI_HCD_PLATFORM is not set
+# CONFIG_USB_EHCI_MXC is not set
+CONFIG_USB_EHCI_PCI=y
+CONFIG_USB_ETH=m
+# CONFIG_USB_ETH_EEM is not set
+CONFIG_USB_ETH_RNDIS=y
+CONFIG_USB_F_ECM=m
+CONFIG_USB_F_RNDIS=m
+CONFIG_USB_F_SUBSET=m
+CONFIG_USB_GADGET=y
+# CONFIG_USB_IMX21_HCD is not set
+CONFIG_USB_LIBCOMPOSITE=m
+CONFIG_USB_MXS_PHY=y
+CONFIG_USB_PHY=y
CONFIG_USB_SUPPORT=y
+# CONFIG_USB_UHCI_HCD is not set
+CONFIG_USB_U_ETHER=m
CONFIG_USE_OF=y
CONFIG_VECTORS_BASE=0xffff0000
CONFIG_VFP=y
diff --git a/target/linux/imx6/image/Makefile b/target/linux/imx6/image/Makefile
index 7407db8037..3ccece7c19 100644
--- a/target/linux/imx6/image/Makefile
+++ b/target/linux/imx6/image/Makefile
@@ -86,8 +86,7 @@ define Device/ventana
imx6q-gw551x \
imx6q-gw552x \
imx6q-gw553x
- DEVICE_PACKAGES := kmod-sky2 kmod-usb-chipidea-imx kmod-usb-mxs-phy \
- kmod-sound-core kmod-sound-soc-imx kmod-sound-soc-imx-sgtl5000 \
+ DEVICE_PACKAGES := kmod-sky2 kmod-sound-core kmod-sound-soc-imx kmod-sound-soc-imx-sgtl5000 \
kmod-can kmod-can-flexcan kmod-can-raw \
kmod-hwmon-gsc \
kmod-leds-gpio kmod-pps-gpio \
@@ -116,7 +115,6 @@ endef
define Device/wandboard
DEVICE_TITLE := Wandboard Dual
DEVICE_DTS := imx6dl-wandboard
- DEVICE_PACKAGES := kmod-usb-chipidea-imx kmod-usb-mxs-phy
endef
TARGET_DEVICES += \
diff --git a/target/linux/imx6/profiles/100-generic.mk b/target/linux/imx6/profiles/100-generic.mk
index 9d981fdc02..218cd69404 100644
--- a/target/linux/imx6/profiles/100-generic.mk
+++ b/target/linux/imx6/profiles/100-generic.mk
@@ -8,8 +8,6 @@
define Profile/Generic
PRIORITY:=1
NAME:=Generic (default)
- PACKAGES:= \
- kmod-usb-chipidea-imx kmod-usb-mxs-phy
endef
define Profile/Generic/Description