aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/imx6
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2014-02-27 22:41:40 +0000
committerLuka Perkov <luka@openwrt.org>2014-02-27 22:41:40 +0000
commit6531bde627f10327ba1db14f2114866f4d866333 (patch)
tree7b22663f80c749ae45a624bcc5033dcd075b27cd /target/linux/imx6
parent8a1b7ef11b7928abe73074c48758985ba9330351 (diff)
downloadupstream-6531bde627f10327ba1db14f2114866f4d866333.tar.gz
upstream-6531bde627f10327ba1db14f2114866f4d866333.tar.bz2
upstream-6531bde627f10327ba1db14f2114866f4d866333.zip
imx6: optimize for NEON FPU hardware
The IMX6 SoC uses an ARM Cortext-A9 which has both NEON and VFPv3 hardware blocks. This will tune gcc to use neon instead of vfpv3 which will outperform VFPv3. Signed-off-by: Tim Harvey <tharvey@gateworks.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39760 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/imx6')
-rw-r--r--target/linux/imx6/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/imx6/Makefile b/target/linux/imx6/Makefile
index cee5b45423..688e355393 100644
--- a/target/linux/imx6/Makefile
+++ b/target/linux/imx6/Makefile
@@ -11,7 +11,7 @@ BOARD:=imx6
BOARDNAME:=Freescale i.MX 6 Series
FEATURES:=audio display fpu gpio pcie rtc usb usbgadget squashfs targz ubifs
CPU_TYPE:=cortex-a9
-CPU_SUBTYPE:=vfpv3
+CPU_SUBTYPE:=neon
MAINTAINER:=Luka Perkov <luka@openwrt.org>
LINUX_VERSION:=3.10.32