aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/imx6/profiles/120-gateworks.mk
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-10-18 00:02:45 +0000
committerLuka Perkov <luka@openwrt.org>2013-10-18 00:02:45 +0000
commit9252c452cd6e76c8c004642b060b0d0390b80a4b (patch)
treec1601580aa1b0374b5b31594c7340c8a5041763c /target/linux/imx6/profiles/120-gateworks.mk
parentc2338633c0c389d19d44baf5c96d379d64fdc58c (diff)
downloadupstream-9252c452cd6e76c8c004642b060b0d0390b80a4b.tar.gz
upstream-9252c452cd6e76c8c004642b060b0d0390b80a4b.tar.bz2
upstream-9252c452cd6e76c8c004642b060b0d0390b80a4b.zip
imx6: reorganize build system
Changes include: * switching to profiles * adding ubifs support * building image for GW54XX board Signed-off-by: Luka Perkov <luka@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38441 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/imx6/profiles/120-gateworks.mk')
-rw-r--r--target/linux/imx6/profiles/120-gateworks.mk57
1 files changed, 57 insertions, 0 deletions
diff --git a/target/linux/imx6/profiles/120-gateworks.mk b/target/linux/imx6/profiles/120-gateworks.mk
new file mode 100644
index 0000000000..9d43537ba7
--- /dev/null
+++ b/target/linux/imx6/profiles/120-gateworks.mk
@@ -0,0 +1,57 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/IMX6Q_GW5400_A
+ NAME:=Gateworks Ventana GW5400-A
+ PACKAGES:= \
+ kmod-thermal-imx kmod-usb-chipidea kmod-usb-mxs-phy
+endef
+
+define Profile/IMX6Q_GW5400_A/Description
+ The Gateworks GW5400-A family of products is based on the Freescale i.MX6Q SoC
+ and offers a large variety of peripherals such as:
+
+ * DDR3
+ * SPI FLASH
+ * 6x PCIe (3x with USB)
+ * Optional expansion for additional USB/PCI based periperhals
+ * 1x USB EHCI
+ * 1x USB OTG
+ * HDMI Audio/Video in/out
+ * Analog Video in/out
+ * Analog Audio in/out
+ * Gateworks System Controller
+endef
+
+$(eval $(call Profile,IMX6Q_GW5400_A))
+
+define Profile/IMX6Q_GW54XX
+ NAME:=Gateworks Ventana GW54XX
+ PACKAGES:= \
+ kmod-thermal-imx kmod-usb-chipidea kmod-usb-mxs-phy
+endef
+
+define Profile/IMX6Q_GW54XX/Description
+ The Gateworks GW54xx family of products is based on the Freescale i.MX6Q SoC
+ and offers a large variety of peripherals such as:
+
+ * DDR3
+ * NAND FLASH
+ * 6x PCIe (3x with USB)
+ * Optional expansion for additional USB/PCI based periperhals
+ * 1x USB EHCI
+ * 1x USB OTG
+ * HDMI Audio/Video in/out
+ * Analog Video in/out
+ * Analog Audio in/out
+ * Gateworks System Controller
+endef
+
+IMX6Q_GW54XX_UBIFS_OPTS:="-m 2048 -e 124KiB -c 1912"
+IMX6Q_GW54XX_UBI_OPTS:="-m 2048 -p 128KiB -s 2048"
+
+$(eval $(call Profile,IMX6Q_GW54XX))