aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/imx6/patches-4.9
diff options
context:
space:
mode:
authorTim Harvey <tharvey@gateworks.com>2018-02-15 08:34:38 -0800
committerJohn Crispin <john@phrozen.org>2018-02-19 09:32:43 +0100
commit1188f35a986a78475819bc5550a8a7bc2d21b16c (patch)
tree8e3b4d4053cce50aa749e43228709f83ef431e13 /target/linux/imx6/patches-4.9
parent8f9668f46c8ab8f9020d83ded7a4007779904b52 (diff)
downloadupstream-1188f35a986a78475819bc5550a8a7bc2d21b16c.tar.gz
upstream-1188f35a986a78475819bc5550a8a7bc2d21b16c.tar.bz2
upstream-1188f35a986a78475819bc5550a8a7bc2d21b16c.zip
imx6: remove support for 4.9
Signed-off-by: Tim Harvey <tharvey@gateworks.com> Tested-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
Diffstat (limited to 'target/linux/imx6/patches-4.9')
-rw-r--r--target/linux/imx6/patches-4.9/0001-arm-dts-imx-add-gateworks-ventana-gw5904-support.patch18
-rw-r--r--target/linux/imx6/patches-4.9/100-bootargs.patch11
-rw-r--r--target/linux/imx6/patches-4.9/200-disable-msi.patch22
-rw-r--r--target/linux/imx6/patches-4.9/210-disable-uart-dma.patch23
4 files changed, 0 insertions, 74 deletions
diff --git a/target/linux/imx6/patches-4.9/0001-arm-dts-imx-add-gateworks-ventana-gw5904-support.patch b/target/linux/imx6/patches-4.9/0001-arm-dts-imx-add-gateworks-ventana-gw5904-support.patch
deleted file mode 100644
index 1bfbf99ca0..0000000000
--- a/target/linux/imx6/patches-4.9/0001-arm-dts-imx-add-gateworks-ventana-gw5904-support.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- a/arch/arm/boot/dts/Makefile
-+++ b/arch/arm/boot/dts/Makefile
-@@ -339,6 +339,7 @@ dtb-$(CONFIG_SOC_IMX6Q) += \
- imx6dl-gw551x.dtb \
- imx6dl-gw552x.dtb \
- imx6dl-gw553x.dtb \
-+ imx6dl-gw5904.dtb \
- imx6dl-hummingboard.dtb \
- imx6dl-nit6xlite.dtb \
- imx6dl-nitrogen6x.dtb \
-@@ -379,6 +380,7 @@ dtb-$(CONFIG_SOC_IMX6Q) += \
- imx6q-gw551x.dtb \
- imx6q-gw552x.dtb \
- imx6q-gw553x.dtb \
-+ imx6q-gw5904.dtb \
- imx6q-h100.dtb \
- imx6q-hummingboard.dtb \
- imx6q-icore-rqs.dtb \
diff --git a/target/linux/imx6/patches-4.9/100-bootargs.patch b/target/linux/imx6/patches-4.9/100-bootargs.patch
deleted file mode 100644
index 0954391203..0000000000
--- a/target/linux/imx6/patches-4.9/100-bootargs.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/arch/arm/boot/dts/imx6dl-wandboard.dts
-+++ b/arch/arm/boot/dts/imx6dl-wandboard.dts
-@@ -19,4 +19,8 @@
- memory {
- reg = <0x10000000 0x40000000>;
- };
-+
-+ chosen {
-+ bootargs = "console=ttymxc0,115200";
-+ };
- };
diff --git a/target/linux/imx6/patches-4.9/200-disable-msi.patch b/target/linux/imx6/patches-4.9/200-disable-msi.patch
deleted file mode 100644
index 290147c944..0000000000
--- a/target/linux/imx6/patches-4.9/200-disable-msi.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-The IMX6 PCIe host controller does not fire legacy interrupts when MSI is
-enabled. A patch is being worked on upstream to only enable MSI at runtime
-when needed, but until that is ready we will allow MSI to be disabled.
-
---- a/drivers/pci/host/Kconfig
-+++ b/drivers/pci/host/Kconfig
-@@ -51,7 +51,6 @@ config PCIE_DW_PLAT
-
- config PCIE_DW
- bool
-- depends on PCI_MSI_IRQ_DOMAIN
-
- config PCI_EXYNOS
- bool "Samsung Exynos PCIe controller"
-@@ -63,7 +62,6 @@ config PCI_EXYNOS
- config PCI_IMX6
- bool "Freescale i.MX6 PCIe controller"
- depends on SOC_IMX6Q
-- depends on PCI_MSI_IRQ_DOMAIN
- select PCIEPORTBUS
- select PCIE_DW
-
diff --git a/target/linux/imx6/patches-4.9/210-disable-uart-dma.patch b/target/linux/imx6/patches-4.9/210-disable-uart-dma.patch
deleted file mode 100644
index 6abbb93301..0000000000
--- a/target/linux/imx6/patches-4.9/210-disable-uart-dma.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-Based on following upstream patch by Tim Harvey (Gateworks):
-
-https://github.com/Gateworks/openwrt/commit/80a01b6582f94c4547f39d3a25e0a1e9b6eb9877
-
-TX complete DMA messages are getting missed.
-This is also currently an issue in mainline.
-For now we will disable DMA in serial/imx.c.
-
-This resolves an issue encountered with RS485 transmit.
-
---- a/drivers/tty/serial/imx.c
-+++ b/drivers/tty/serial/imx.c
-@@ -1268,10 +1268,6 @@ static int imx_startup(struct uart_port
-
- writel(temp & ~UCR4_DREN, sport->port.membase + UCR4);
-
-- /* Can we enable the DMA support? */
-- if (!uart_console(port) && !sport->dma_is_inited)
-- imx_uart_dma_init(sport);
--
- spin_lock_irqsave(&sport->port.lock, flags);
- /* Reset fifo's and state machines */
- i = 100;