aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/imx6/patches-3.10/010-pcie-backport-fixes.patch
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-09-20 01:59:32 +0000
committerLuka Perkov <luka@openwrt.org>2013-09-20 01:59:32 +0000
commit964174bc4f9863f990ea1c454fbaf5e758dfcd0d (patch)
treee75470287854be987c467ae850da99066bd3e1e2 /target/linux/imx6/patches-3.10/010-pcie-backport-fixes.patch
parente568b3d4ff8e10cb7fa0c1726feedd42e21ea9a5 (diff)
downloadupstream-964174bc4f9863f990ea1c454fbaf5e758dfcd0d.tar.gz
upstream-964174bc4f9863f990ea1c454fbaf5e758dfcd0d.tar.bz2
upstream-964174bc4f9863f990ea1c454fbaf5e758dfcd0d.zip
imx6: update PCIe driver
Signed-off-by: Tim Harvey <tharvey@gateworks.com> Signed-off-by: Luka Perkov <luka@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38080 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/imx6/patches-3.10/010-pcie-backport-fixes.patch')
-rw-r--r--target/linux/imx6/patches-3.10/010-pcie-backport-fixes.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/imx6/patches-3.10/010-pcie-backport-fixes.patch b/target/linux/imx6/patches-3.10/010-pcie-backport-fixes.patch
new file mode 100644
index 0000000000..aef6b05f48
--- /dev/null
+++ b/target/linux/imx6/patches-3.10/010-pcie-backport-fixes.patch
@@ -0,0 +1,17 @@
+--- a/drivers/pci/Kconfig
++++ b/drivers/pci/Kconfig
+@@ -125,3 +125,5 @@ config PCI_IOAPIC
+ config PCI_LABEL
+ def_bool y if (DMI || ACPI)
+ select NLS
++
++source "drivers/pci/host/Kconfig"
+--- a/drivers/pci/Makefile
++++ b/drivers/pci/Makefile
+@@ -67,3 +67,6 @@ obj-$(CONFIG_XEN_PCIDEV_FRONTEND) += xen
+ obj-$(CONFIG_OF) += of.o
+
+ ccflags-$(CONFIG_PCI_DEBUG) := -DDEBUG
++
++# PCI host controller drivers
++obj-y += host/