aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/imx6/Makefile
diff options
context:
space:
mode:
authorPiotr Dymacz <pepe2k@gmail.com>2021-03-28 16:56:18 +0200
committerPiotr Dymacz <pepe2k@gmail.com>2021-11-03 12:45:40 +0100
commitd1c66eacabe11f8088f2d49e94b80dfa8a0f94f7 (patch)
tree64d43ea3b3eaa8c8780206ee78e4e0b9ea482d56 /target/linux/imx6/Makefile
parent7abde5037d572cb28cc8ae41b39c76323eebc4a6 (diff)
downloadupstream-d1c66eacabe11f8088f2d49e94b80dfa8a0f94f7.tar.gz
upstream-d1c66eacabe11f8088f2d49e94b80dfa8a0f94f7.tar.bz2
upstream-d1c66eacabe11f8088f2d49e94b80dfa8a0f94f7.zip
imx6: rename target to 'imx'
This is first step in migrating to a generic i.MX target which in the next steps will also get divided into arch-specific subtargets. In the result, this will make it possible to support, within a single target, also other modern NXP i.MX families, like the i.MX 7, i.MX 8 or recently introduced i.MX 9. Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Diffstat (limited to 'target/linux/imx6/Makefile')
-rw-r--r--target/linux/imx6/Makefile23
1 files changed, 0 insertions, 23 deletions
diff --git a/target/linux/imx6/Makefile b/target/linux/imx6/Makefile
deleted file mode 100644
index e735d1d885..0000000000
--- a/target/linux/imx6/Makefile
+++ /dev/null
@@ -1,23 +0,0 @@
-# SPDX-License-Identifier: GPL-2.0-only
-#
-# Copyright (C) 2013-2014 OpenWrt.org
-
-include $(TOPDIR)/rules.mk
-
-ARCH:=arm
-BOARD:=imx6
-BOARDNAME:=NXP i.MX 6
-FEATURES:=audio display fpu gpio pcie rtc usb usbgadget squashfs targz nand ubifs boot-part rootfs-part
-CPU_TYPE:=cortex-a9
-CPU_SUBTYPE:=neon
-
-KERNEL_PATCHVER:=5.4
-KERNEL_TESTING_PATCHVER:=5.10
-
-include $(INCLUDE_DIR)/target.mk
-
-KERNELNAME:=zImage dtbs
-
-DEFAULT_PACKAGES += uboot-envtools mkf2fs e2fsprogs blkid
-
-$(eval $(call BuildTarget))