aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/imx23/patches/105-imx23-dcp.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-08-23 17:31:04 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-08-23 17:31:04 +0000
commit043edd80744308e9d1b8c0bf2213bd7a71770cb1 (patch)
tree8b1ccfd0ecdc4680df553aae16f6f937193a5b4c /target/linux/imx23/patches/105-imx23-dcp.patch
parent6f232cba6241c248000fbca5e7261c1a79accbb4 (diff)
downloadupstream-043edd80744308e9d1b8c0bf2213bd7a71770cb1.tar.gz
upstream-043edd80744308e9d1b8c0bf2213bd7a71770cb1.tar.bz2
upstream-043edd80744308e9d1b8c0bf2213bd7a71770cb1.zip
kernel: update 3.10 to 3.10.9
Also refresh 3.10 patches. Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 37832
Diffstat (limited to 'target/linux/imx23/patches/105-imx23-dcp.patch')
-rw-r--r--target/linux/imx23/patches/105-imx23-dcp.patch21
1 files changed, 6 insertions, 15 deletions
diff --git a/target/linux/imx23/patches/105-imx23-dcp.patch b/target/linux/imx23/patches/105-imx23-dcp.patch
index cbc25a06b3..ae74209775 100644
--- a/target/linux/imx23/patches/105-imx23-dcp.patch
+++ b/target/linux/imx23/patches/105-imx23-dcp.patch
@@ -1,10 +1,8 @@
-diff --git a/drivers/crypto/Kconfig b/drivers/crypto/Kconfig
-index dffb855..3e11215 100644
--- a/drivers/crypto/Kconfig
+++ b/drivers/crypto/Kconfig
-@@ -286,6 +286,16 @@ config CRYPTO_DEV_SAHARA
- This option enables support for the SAHARA HW crypto accelerator
- found in some Freescale i.MX chips.
+@@ -287,6 +287,16 @@ config CRYPTO_DEV_SAHARA
+ This option enables support for the SAHARA HW crypto accelerator
+ found in some Freescale i.MX chips.
+config CRYPTO_DEV_DCP
+ tristate "Support for the DCP engine"
@@ -17,13 +15,11 @@ index dffb855..3e11215 100644
+ capabilities of the DCP co-processor
+
config CRYPTO_DEV_S5P
- tristate "Support for Samsung S5PV210 crypto accelerator"
- depends on ARCH_S5PV210
-diff --git a/drivers/crypto/Makefile b/drivers/crypto/Makefile
-index 38ce13d..b4946dd 100644
+ tristate "Support for Samsung S5PV210 crypto accelerator"
+ depends on ARCH_S5PV210
--- a/drivers/crypto/Makefile
+++ b/drivers/crypto/Makefile
-@@ -13,6 +13,7 @@ obj-$(CONFIG_CRYPTO_DEV_OMAP_SHAM) += omap-sham.o
+@@ -13,6 +13,7 @@ obj-$(CONFIG_CRYPTO_DEV_OMAP_SHAM) += om
obj-$(CONFIG_CRYPTO_DEV_OMAP_AES) += omap-aes.o
obj-$(CONFIG_CRYPTO_DEV_PICOXCELL) += picoxcell_crypto.o
obj-$(CONFIG_CRYPTO_DEV_SAHARA) += sahara.o
@@ -31,9 +27,6 @@ index 38ce13d..b4946dd 100644
obj-$(CONFIG_CRYPTO_DEV_S5P) += s5p-sss.o
obj-$(CONFIG_CRYPTO_DEV_TEGRA_AES) += tegra-aes.o
obj-$(CONFIG_CRYPTO_DEV_UX500) += ux500/
-diff --git a/drivers/crypto/dcp.c b/drivers/crypto/dcp.c
-new file mode 100644
-index 0000000..eea194c
--- /dev/null
+++ b/drivers/crypto/dcp.c
@@ -0,0 +1,925 @@
@@ -962,5 +955,3 @@ index 0000000..eea194c
+MODULE_AUTHOR("Tobias Rauter <tobias.rau...@gmail.com>");
+MODULE_DESCRIPTION("Freescale DCP Crypto Driver");
+MODULE_LICENSE("GPL");
-
-