aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/imx/profiles
diff options
context:
space:
mode:
authorPiotr Dymacz <pepe2k@gmail.com>2021-03-28 16:56:18 +0200
committerPiotr Dymacz <pepe2k@gmail.com>2021-11-03 12:45:40 +0100
commitd1c66eacabe11f8088f2d49e94b80dfa8a0f94f7 (patch)
tree64d43ea3b3eaa8c8780206ee78e4e0b9ea482d56 /target/linux/imx/profiles
parent7abde5037d572cb28cc8ae41b39c76323eebc4a6 (diff)
downloadupstream-d1c66eacabe11f8088f2d49e94b80dfa8a0f94f7.tar.gz
upstream-d1c66eacabe11f8088f2d49e94b80dfa8a0f94f7.tar.bz2
upstream-d1c66eacabe11f8088f2d49e94b80dfa8a0f94f7.zip
imx6: rename target to 'imx'
This is first step in migrating to a generic i.MX target which in the next steps will also get divided into arch-specific subtargets. In the result, this will make it possible to support, within a single target, also other modern NXP i.MX families, like the i.MX 7, i.MX 8 or recently introduced i.MX 9. Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Diffstat (limited to 'target/linux/imx/profiles')
-rw-r--r--target/linux/imx/profiles/100-default.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/imx/profiles/100-default.mk b/target/linux/imx/profiles/100-default.mk
new file mode 100644
index 0000000000..5e90724a58
--- /dev/null
+++ b/target/linux/imx/profiles/100-default.mk
@@ -0,0 +1,14 @@
+# SPDX-License-Identifier: GPL-2.0-only
+#
+# Copyright (C) 2013 OpenWrt.org
+
+define Profile/Default
+ PRIORITY:=1
+ NAME:=Default Profile
+endef
+
+define Profile/Default/Description
+ Package set compatible with most NXP i.MX based boards.
+endef
+
+$(eval $(call Profile,Default))