aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/imx/Makefile
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2022-03-31 14:42:29 +0200
committerPetr Štetiar <ynezz@true.cz>2022-03-31 17:30:14 +0200
commit9d26651174c1173809021af335a5f4ea8f91a336 (patch)
tree0fa6fc1609a6dc72e3609f52e7627cad52da3f29 /target/linux/imx/Makefile
parent5959c4645605ae759a331b6b700f2d9bf8547705 (diff)
downloadupstream-9d26651174c1173809021af335a5f4ea8f91a336.tar.gz
upstream-9d26651174c1173809021af335a5f4ea8f91a336.tar.bz2
upstream-9d26651174c1173809021af335a5f4ea8f91a336.zip
imx: make 5.15 default kernel and remove 5.10 support
In imx target we're sharing single, version agnostic kernel `config-default` file, which doesn't work very well with current 5.10 and upcoming 5.15 kernel symbols as recent rebase onto 5.15 kernel introduced in commit 2b395c298247 ("imx: update config for 5.15) has introduced following regression with 5.10 kernel: Marvell 88E6xxx Ethernet switch fabric support (NET_DSA_MV88E6XXX) [Y/n/m/?] y Switch Global 2 Registers support (NET_DSA_MV88E6XXX_GLOBAL2) [Y/n/?] (NEW) That NET_DSA_MV88E6XXX_GLOBAL2 kernel config symbol has been removed in upstream commit 63368a7416df ("net: dsa: mv88e6xxx: Make global2 support mandatory") in kernel version 5.12. This issue could be probably fixed by introduction of separate kernel config files for each currently used kernel versions and subtarget, but it is not worth the hassle and resources as imx target is running mostly upstream kernel, so lets fix it by switching to 5.15 version instead. Fixes: 2b395c298247 ("imx: update config for 5.15") Acked-by: Piotr Dymacz <pepe2k@gmail.com> Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'target/linux/imx/Makefile')
-rw-r--r--target/linux/imx/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/target/linux/imx/Makefile b/target/linux/imx/Makefile
index ea035d6da6..5fb7a4d339 100644
--- a/target/linux/imx/Makefile
+++ b/target/linux/imx/Makefile
@@ -10,8 +10,7 @@ BOARDNAME:=NXP i.MX
FEATURES:=audio display fpu gpio pcie rtc usb usbgadget squashfs targz nand ubifs boot-part rootfs-part
SUBTARGETS:=cortexa7 cortexa9
-KERNEL_PATCHVER:=5.10
-KERNEL_TESTING_PATCHVER:=5.15
+KERNEL_PATCHVER:=5.15
include $(INCLUDE_DIR)/target.mk