aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/image
diff options
context:
space:
mode:
authorWaldemar Brodkorb <wbx@openwrt.org>2006-01-09 16:03:36 +0000
committerWaldemar Brodkorb <wbx@openwrt.org>2006-01-09 16:03:36 +0000
commitc021f138d6ec2f66d081cb1960a529ebc6b99cd9 (patch)
tree951b416b967f6a07264bdf29211f91d9558f93b1 /target/linux/image
parentdb7d9885a7ce804bd6d03e8ee6694bcb733656c2 (diff)
downloadupstream-c021f138d6ec2f66d081cb1960a529ebc6b99cd9.tar.gz
upstream-c021f138d6ec2f66d081cb1960a529ebc6b99cd9.tar.bz2
upstream-c021f138d6ec2f66d081cb1960a529ebc6b99cd9.zip
add updates for atheros SOC support from Mike A., thx
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2866 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/image')
-rw-r--r--target/linux/image/squashfs.mk9
1 files changed, 8 insertions, 1 deletions
diff --git a/target/linux/image/squashfs.mk b/target/linux/image/squashfs.mk
index 63eba445a0..450718153c 100644
--- a/target/linux/image/squashfs.mk
+++ b/target/linux/image/squashfs.mk
@@ -1,3 +1,10 @@
+ifeq ($(BR2_LINUX_2_4_AR531X),)
+ endian := be
+else
+ endian := le
+endif
+
+
squashfs-prepare:
$(MAKE) -C squashfs prepare $(MAKE_TRACE)
@@ -10,7 +17,7 @@ squashfs-clean:
$(KDIR)/root.squashfs: install-prepare
@mkdir -p $(KDIR)/root/jffs
- $(STAGING_DIR)/bin/mksquashfs-lzma $(KDIR)/root $@ -nopad -noappend -root-owned -le $(MAKE_TRACE)
+ $(STAGING_DIR)/bin/mksquashfs-lzma $(KDIR)/root $@ -nopad -noappend -root-owned -$(endian) $(MAKE_TRACE)
ifeq ($(IB),)
squashfs-install: compile-targets $(BOARD)-compile