aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/image
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-07-25 15:40:23 +0000
committerNicolas Thill <nico@openwrt.org>2005-07-25 15:40:23 +0000
commit92c70bff6423a67a2ee3d3bdfefffae88aae7e59 (patch)
treee2b48a5bc1e3887ee0186714507fd14827541fe3 /target/linux/image
parent57db8eb1766ba3ccfa458b36ba6efca13589b2db (diff)
downloadupstream-92c70bff6423a67a2ee3d3bdfefffae88aae7e59.tar.gz
upstream-92c70bff6423a67a2ee3d3bdfefffae88aae7e59.tar.bz2
upstream-92c70bff6423a67a2ee3d3bdfefffae88aae7e59.zip
add preliminary support for soekris boards
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1564 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/image')
-rw-r--r--target/linux/image/Makefile4
-rw-r--r--target/linux/image/soekris/Makefile10
2 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/image/Makefile b/target/linux/image/Makefile
index 73e67a3d1c..6509952fac 100644
--- a/target/linux/image/Makefile
+++ b/target/linux/image/Makefile
@@ -14,6 +14,10 @@ ifeq ($(BR2_TARGET_ROOTFS_SQUASHFS_LZMA),y)
include ./squashfs.mk
endif
+ifeq ($(BR2_TARGET_ROOTFS_TGZ),y)
+include ./tgz.mk
+endif
+
prepare:
compile:
install:
diff --git a/target/linux/image/soekris/Makefile b/target/linux/image/soekris/Makefile
new file mode 100644
index 0000000000..bfb2770ef3
--- /dev/null
+++ b/target/linux/image/soekris/Makefile
@@ -0,0 +1,10 @@
+include $(TOPDIR)/rules.mk
+
+KDIR:=$(BUILD_DIR)/linux-$(KERNEL)-$(BOARD)
+
+$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-rootfs.tar.gz: $(KDIR)/rootfs.tar.gz
+ cp $^ $@
+
+prepare:
+compile:
+install: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-rootfs.tar.gz