aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/image
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-08-14 20:31:12 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-08-14 20:31:12 +0000
commit6271c3f8703a0686d35fa818bfc2aba2488c07e7 (patch)
treeb20c9cb9b3c5091acd702e4923ccb8b6466e60f9 /target/linux/image
parentc6a1829d3cc17aef9f2e3178cb1d894c9dd6c0fa (diff)
downloadupstream-6271c3f8703a0686d35fa818bfc2aba2488c07e7.tar.gz
upstream-6271c3f8703a0686d35fa818bfc2aba2488c07e7.tar.bz2
upstream-6271c3f8703a0686d35fa818bfc2aba2488c07e7.zip
fix lzma loader dependency
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1674 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/image')
-rw-r--r--target/linux/image/brcm/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/target/linux/image/brcm/Makefile b/target/linux/image/brcm/Makefile
index f551b84bee..c0c83c52f0 100644
--- a/target/linux/image/brcm/Makefile
+++ b/target/linux/image/brcm/Makefile
@@ -15,7 +15,7 @@ ifeq ($(IB),)
$(KDIR)/vmlinux.lzma: $(KDIR)/vmlinux
cat $^ | $(STAGING_DIR)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $@ || (rm -f $@ && false)
-$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx: $(KDIR)/vmlinux.lzma
+$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx: $(KDIR)/vmlinux.lzma compile
endif
ifeq ($(FS),jffs2-8MB)
@@ -54,13 +54,12 @@ ifeq ($(IB),)
clean: lzma-loader-clean
prepare: lzma-loader-prepare
compile: lzma-loader-compile
-install: compile $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx
else
clean:
prepare:
compile:
-install: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx
endif
+install: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx
install-ib:
mkdir -p $(IB_DIR)/staging_dir_$(ARCH)/bin
cp -dpR $(STAGING_DIR)/bin/addpattern $(STAGING_DIR)/bin/trx $(STAGING_DIR)/bin/motorola-bin $(IB_DIR)/staging_dir_$(ARCH)/bin