aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/image/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-05-31 20:14:08 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-05-31 20:14:08 +0000
commita65db49b1fe4cf8d94a15efb5fbe62a593dc005e (patch)
tree51a3331a48799f31c75dff460b4cd37a8de5287b /target/linux/image/Makefile
parent272d1962e4b2ab5874662c40dbaca5561dd10d04 (diff)
downloadupstream-a65db49b1fe4cf8d94a15efb5fbe62a593dc005e.tar.gz
upstream-a65db49b1fe4cf8d94a15efb5fbe62a593dc005e.tar.bz2
upstream-a65db49b1fe4cf8d94a15efb5fbe62a593dc005e.zip
fix root filesystem path
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@3871 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/image/Makefile')
-rw-r--r--target/linux/image/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/target/linux/image/Makefile b/target/linux/image/Makefile
index ce807b3027..3b82343398 100644
--- a/target/linux/image/Makefile
+++ b/target/linux/image/Makefile
@@ -33,11 +33,11 @@ install-ib:
$(CP) $(BUILD_DIR)/linux-$(KERNEL)-$(BOARD)/kernel[-_]*.ipk $(IB_DIR)/build_$(ARCH)/linux-$(KERNEL)-$(BOARD)/
install-prepare:
- find $(KDIR)/root -type f -not -perm +0100 | xargs chmod 0644
- find $(KDIR)/root -type f -perm +0100 | xargs chmod 0755
- find $(KDIR)/root -type d | xargs chmod 0755
- mkdir -p $(KDIR)/root/tmp
- chmod 0777 $(KDIR)/root/tmp
+ find $(BUILD_DIR)/root -type f -not -perm +0100 | xargs chmod 0644
+ find $(BUILD_DIR)/root -type f -perm +0100 | xargs chmod 0755
+ find $(BUILD_DIR)/root -type d | xargs chmod 0755
+ mkdir -p $(BUILD_DIR)/root/tmp
+ chmod 0777 $(BUILD_DIR)/root/tmp
rebuild: clean prepare compile install
clean: