aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ifxmips/patches-2.6.30/150-wdt.patch
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2009-10-08 22:24:49 +0000
committerJohn Crispin <blogic@openwrt.org>2009-10-08 22:24:49 +0000
commitfe2eb2406d5600eb56d91c967a2d92c14eb6cc18 (patch)
treee263c035214c31d62f8665c339ba16b257c4667c /target/linux/ifxmips/patches-2.6.30/150-wdt.patch
parent6ca9f5f2d7721ab48f7e245a72b0b8f381f8dc7e (diff)
downloadupstream-fe2eb2406d5600eb56d91c967a2d92c14eb6cc18.tar.gz
upstream-fe2eb2406d5600eb56d91c967a2d92c14eb6cc18.tar.bz2
upstream-fe2eb2406d5600eb56d91c967a2d92c14eb6cc18.zip
ifxmips: move header files, split up patches, rename some files
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18010 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ifxmips/patches-2.6.30/150-wdt.patch')
-rw-r--r--target/linux/ifxmips/patches-2.6.30/150-wdt.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/target/linux/ifxmips/patches-2.6.30/150-wdt.patch b/target/linux/ifxmips/patches-2.6.30/150-wdt.patch
new file mode 100644
index 0000000000..9f589163ac
--- /dev/null
+++ b/target/linux/ifxmips/patches-2.6.30/150-wdt.patch
@@ -0,0 +1,29 @@
+Index: linux-2.6.30.5/drivers/watchdog/Makefile
+===================================================================
+--- linux-2.6.30.5.orig/drivers/watchdog/Makefile 2009-08-16 23:19:38.000000000 +0200
++++ linux-2.6.30.5/drivers/watchdog/Makefile 2009-09-02 18:29:51.000000000 +0200
+@@ -105,6 +105,7 @@
+ obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o
+ obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
+ obj-$(CONFIG_TXX9_WDT) += txx9wdt.o
++obj-$(CONFIG_IFXMIPS_WDT) += ifxmips_wdt.o
+
+ # PARISC Architecture
+
+Index: linux-2.6.30.5/drivers/watchdog/Kconfig
+===================================================================
+--- linux-2.6.30.5.orig/drivers/watchdog/Kconfig 2009-08-16 23:19:38.000000000 +0200
++++ linux-2.6.30.5/drivers/watchdog/Kconfig 2009-09-02 18:29:51.000000000 +0200
+@@ -764,6 +764,12 @@
+ help
+ Hardware driver for the built-in watchdog timer on TXx9 MIPS SoCs.
+
++config IFXMIPS_WDT
++ bool "IFXMips watchdog"
++ depends on IFXMIPS
++ help
++ Hardware driver for the IFXMIPS Watchdog Timer.
++
+ # PARISC Architecture
+
+ # POWERPC Architecture