aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ifxmips/nfs
diff options
context:
space:
mode:
authorOpenWrt Developers <openwrt-devel@openwrt.org>2008-11-20 18:31:00 +0000
committerOpenWrt Developers <openwrt-devel@openwrt.org>2008-11-20 18:31:00 +0000
commitf9cc1cbeeddb0c587d1c0f9f6176e8965683fe40 (patch)
treec27e65457073e14fccdb143d901b02f5c64dd2ad /target/linux/ifxmips/nfs
parent057c85aca2bf834cd920308625f93fa84de3d26d (diff)
downloadupstream-f9cc1cbeeddb0c587d1c0f9f6176e8965683fe40.tar.gz
upstream-f9cc1cbeeddb0c587d1c0f9f6176e8965683fe40.tar.bz2
upstream-f9cc1cbeeddb0c587d1c0f9f6176e8965683fe40.zip
[ifxmips] some cleanups:
- fix CPUID detection - update MTD map for checks and sysupgrade - enable subtargets (Generic&NFS) for simpler development - generic cleanups (e.g. from linux checkpatch.pl) git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13295 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ifxmips/nfs')
-rw-r--r--target/linux/ifxmips/nfs/base-files/etc/config/network7
-rwxr-xr-xtarget/linux/ifxmips/nfs/base-files/etc/preinit.arch3
-rw-r--r--target/linux/ifxmips/nfs/config-2.6.2616
-rw-r--r--target/linux/ifxmips/nfs/target.mk8
4 files changed, 34 insertions, 0 deletions
diff --git a/target/linux/ifxmips/nfs/base-files/etc/config/network b/target/linux/ifxmips/nfs/base-files/etc/config/network
new file mode 100644
index 0000000000..f2e8a5ecd5
--- /dev/null
+++ b/target/linux/ifxmips/nfs/base-files/etc/config/network
@@ -0,0 +1,7 @@
+# Copyright (C) 2006 OpenWrt.org
+
+config interface loopback
+ option ifname lo
+ option proto static
+ option ipaddr 127.0.0.1
+ option netmask 255.0.0.0
diff --git a/target/linux/ifxmips/nfs/base-files/etc/preinit.arch b/target/linux/ifxmips/nfs/base-files/etc/preinit.arch
new file mode 100755
index 0000000000..61662bc21d
--- /dev/null
+++ b/target/linux/ifxmips/nfs/base-files/etc/preinit.arch
@@ -0,0 +1,3 @@
+
+echo "- init nfs -"
+exec /sbin/init
diff --git a/target/linux/ifxmips/nfs/config-2.6.26 b/target/linux/ifxmips/nfs/config-2.6.26
new file mode 100644
index 0000000000..137af82d44
--- /dev/null
+++ b/target/linux/ifxmips/nfs/config-2.6.26
@@ -0,0 +1,16 @@
+CONFIG_CRYPTO_ALGAPI=y
+CONFIG_CRYPTO_BLKCIPHER=y
+CONFIG_CRYPTO_CBC=y
+CONFIG_CRYPTO_DES=y
+CONFIG_CRYPTO_MANAGER=y
+CONFIG_CRYPTO_MD5=y
+CONFIG_IP_PNP=y
+# CONFIG_IP_PNP_BOOTP is not set
+# CONFIG_IP_PNP_DHCP is not set
+# CONFIG_IP_PNP_RARP is not set
+CONFIG_LOCKD=y
+CONFIG_NFS_FS=y
+CONFIG_ROOT_NFS=y
+CONFIG_RPCSEC_GSS_KRB5=y
+CONFIG_SUNRPC=y
+CONFIG_SUNRPC_GSS=y
diff --git a/target/linux/ifxmips/nfs/target.mk b/target/linux/ifxmips/nfs/target.mk
new file mode 100644
index 0000000000..8d454e2795
--- /dev/null
+++ b/target/linux/ifxmips/nfs/target.mk
@@ -0,0 +1,8 @@
+BOARDNAME:=NFS Root
+FEATURES:=tgz
+DEVICE_TYPE:=modem
+
+define Target/Description
+ Build images for Infineon CPE devices for NFS boot
+endef
+