aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ifxmips/image/u-boot/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2008-05-11 14:13:15 +0000
committerJohn Crispin <john@openwrt.org>2008-05-11 14:13:15 +0000
commit4d4f7d4c845901f0353c492f05c4f837dfd1e049 (patch)
tree8cad938f65f89fb196fadb1ebae436282f4ee313 /target/linux/ifxmips/image/u-boot/Makefile
parent2b05ed626c650657e29575f209ea80e6553f8a55 (diff)
downloadupstream-4d4f7d4c845901f0353c492f05c4f837dfd1e049.tar.gz
upstream-4d4f7d4c845901f0353c492f05c4f837dfd1e049.tar.bz2
upstream-4d4f7d4c845901f0353c492f05c4f837dfd1e049.zip
add u-boot sources for danube
SVN-Revision: 11108
Diffstat (limited to 'target/linux/ifxmips/image/u-boot/Makefile')
-rw-r--r--target/linux/ifxmips/image/u-boot/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/target/linux/ifxmips/image/u-boot/Makefile b/target/linux/ifxmips/image/u-boot/Makefile
new file mode 100644
index 0000000000..c92a1a3c5b
--- /dev/null
+++ b/target/linux/ifxmips/image/u-boot/Makefile
@@ -0,0 +1,32 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
+
+PKG_NAME:=u-boot
+PKG_VERSION:=1.1.5
+PKG_RELEASE:=1
+
+PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=ftp://ftp.denx.de/pub/u-boot
+PKG_MD5SUM:=579707c8ecbf1ab4127285d2aac2a9ee
+PKG_CAT:=bzcat
+
+include $(INCLUDE_DIR)/package.mk
+
+define Build/Compile
+ cp -r ./files/* $(PKG_BUILD_DIR)
+ cd $(PKG_BUILD_DIR);chmod a+x build_danube.sh;./build_danube.sh
+endef
+
+define Build/InstallDev
+ dd if=$(PKG_BUILD_DIR)/u-boot.ifx of=$(BIN_DIR)/u-boot.ifx bs=64k conv=sync
+endef
+
+$(eval $(call Build/DefaultTargets))