aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/goldfish/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-06-14 20:42:33 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-06-14 20:42:33 +0000
commit2d5f80251c73e1e44c8fdd047ef49dbe051d65aa (patch)
tree74597f2d6eef2e7a6d6338c978b8910f9f947151 /target/linux/goldfish/Makefile
parent157a4ab64660aaca2dd51fa4f82239d3738a1dff (diff)
downloadupstream-2d5f80251c73e1e44c8fdd047ef49dbe051d65aa.tar.gz
upstream-2d5f80251c73e1e44c8fdd047ef49dbe051d65aa.tar.bz2
upstream-2d5f80251c73e1e44c8fdd047ef49dbe051d65aa.zip
add the 'goldfish' target, useful for experimenting with virtual phone hardware (includes the emulator)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16459 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/goldfish/Makefile')
-rw-r--r--target/linux/goldfish/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/goldfish/Makefile b/target/linux/goldfish/Makefile
new file mode 100644
index 0000000000..08fdb6b579
--- /dev/null
+++ b/target/linux/goldfish/Makefile
@@ -0,0 +1,25 @@
+#
+# Copyright (C) 2006-2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=goldfish
+BOARDNAME:=Goldfish (Android Emulator)
+FEATURES:=
+CFLAGS:=-O2 -pipe -march=armv5te -mtune=xscale -funit-at-a-time
+
+LINUX_VERSION:=2.6.30
+
+DEVICE_TYPE=phone
+
+define Target/Description
+ Android emulator virtual platform
+endef
+
+include $(INCLUDE_DIR)/target.mk
+
+$(eval $(call BuildTarget))