aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic
diff options
context:
space:
mode:
authorKoen Vandeputte <koen.vandeputte@ncentric.com>2019-04-29 12:05:49 +0200
committerKoen Vandeputte <koen.vandeputte@ncentric.com>2019-05-02 12:59:26 +0200
commit456f486b53a7cbe7035dca7323f6b5fdb58be444 (patch)
tree9f3657c6775ac8f0502c856ce5e90e780ecc124d /target/linux/generic
parenta9190ee3a41e49e085ab7ad520b757313c2bdf31 (diff)
downloadupstream-456f486b53a7cbe7035dca7323f6b5fdb58be444.tar.gz
upstream-456f486b53a7cbe7035dca7323f6b5fdb58be444.tar.bz2
upstream-456f486b53a7cbe7035dca7323f6b5fdb58be444.zip
kernel: bump 4.9 to 4.9.171
Refreshed all patches. Altered patches: - 150-bridge_allow_receiption_on_disabled_port.patch - 201-extra_optimization.patch Compile-tested on: ar7 Runtime-tested on: none Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
Diffstat (limited to 'target/linux/generic')
-rw-r--r--target/linux/generic/hack-4.9/207-disable-modorder.patch4
-rw-r--r--target/linux/generic/hack-4.9/220-gc_sections.patch4
-rw-r--r--target/linux/generic/hack-4.9/902-debloat_proc.patch2
-rw-r--r--target/linux/generic/pending-4.9/150-bridge_allow_receiption_on_disabled_port.patch14
-rw-r--r--target/linux/generic/pending-4.9/201-extra_optimization.patch8
5 files changed, 17 insertions, 15 deletions
diff --git a/target/linux/generic/hack-4.9/207-disable-modorder.patch b/target/linux/generic/hack-4.9/207-disable-modorder.patch
index c66a4db200..e92f4fa0bf 100644
--- a/target/linux/generic/hack-4.9/207-disable-modorder.patch
+++ b/target/linux/generic/hack-4.9/207-disable-modorder.patch
@@ -15,7 +15,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
--- a/Makefile
+++ b/Makefile
-@@ -1227,7 +1227,6 @@ all: modules
+@@ -1226,7 +1226,6 @@ all: modules
PHONY += modules
modules: $(vmlinux-dirs) $(if $(KBUILD_BUILTIN),vmlinux) modules.builtin
@@ -23,7 +23,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
@$(kecho) ' Building modules, stage 2.';
$(Q)$(MAKE) -f $(srctree)/scripts/Makefile.modpost
$(Q)$(MAKE) -f $(srctree)/scripts/Makefile.fwinst obj=firmware __fw_modbuild
-@@ -1257,7 +1256,6 @@ _modinst_:
+@@ -1256,7 +1255,6 @@ _modinst_:
rm -f $(MODLIB)/build ; \
ln -s $(CURDIR) $(MODLIB)/build ; \
fi
diff --git a/target/linux/generic/hack-4.9/220-gc_sections.patch b/target/linux/generic/hack-4.9/220-gc_sections.patch
index ea6ce0bcf7..732e38aaf0 100644
--- a/target/linux/generic/hack-4.9/220-gc_sections.patch
+++ b/target/linux/generic/hack-4.9/220-gc_sections.patch
@@ -43,8 +43,8 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
-endif
-
ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
- KBUILD_CFLAGS += $(call cc-option,-Oz,-Os)
- KBUILD_CFLAGS += $(call cc-disable-warning,maybe-uninitialized,) $(EXTRA_OPTIMIZATION)
+ KBUILD_CFLAGS += -Os $(call cc-disable-warning,maybe-uninitialized,) $(EXTRA_OPTIMIZATION)
+ else
--- a/arch/arm/Kconfig
+++ b/arch/arm/Kconfig
@@ -81,6 +81,7 @@ config ARM
diff --git a/target/linux/generic/hack-4.9/902-debloat_proc.patch b/target/linux/generic/hack-4.9/902-debloat_proc.patch
index 7c4a48f5ff..ee72d984f9 100644
--- a/target/linux/generic/hack-4.9/902-debloat_proc.patch
+++ b/target/linux/generic/hack-4.9/902-debloat_proc.patch
@@ -244,7 +244,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
}
--- a/mm/vmstat.c
+++ b/mm/vmstat.c
-@@ -1798,10 +1798,12 @@ static int __init setup_vmstat(void)
+@@ -1793,10 +1793,12 @@ static int __init setup_vmstat(void)
cpu_notifier_register_done();
#endif
#ifdef CONFIG_PROC_FS
diff --git a/target/linux/generic/pending-4.9/150-bridge_allow_receiption_on_disabled_port.patch b/target/linux/generic/pending-4.9/150-bridge_allow_receiption_on_disabled_port.patch
index a164f6e7ea..c62eea3124 100644
--- a/target/linux/generic/pending-4.9/150-bridge_allow_receiption_on_disabled_port.patch
+++ b/target/linux/generic/pending-4.9/150-bridge_allow_receiption_on_disabled_port.patch
@@ -15,17 +15,19 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
--- a/net/bridge/br_input.c
+++ b/net/bridge/br_input.c
-@@ -233,7 +233,8 @@ static int br_handle_local_finish(struct
+@@ -231,7 +231,10 @@ static void __br_handle_local_finish(str
+ /* note: already called with rcu_read_lock */
+ static int br_handle_local_finish(struct net *net, struct sock *sk, struct sk_buff *skb)
{
- struct net_bridge_port *p = br_port_get_rcu(skb->dev);
-
- __br_handle_local_finish(skb);
++ struct net_bridge_port *p = br_port_get_rcu(skb->dev);
++
+ if (p->state != BR_STATE_DISABLED)
+ __br_handle_local_finish(skb);
- BR_INPUT_SKB_CB(skb)->brdev = p->br->dev;
- br_pass_frame_up(skb);
-@@ -316,6 +317,15 @@ rx_handler_result_t br_handle_frame(stru
+ /* return 1 to signal the okfn() was called so it's ok to use the skb */
+ return 1;
+@@ -321,6 +324,15 @@ rx_handler_result_t br_handle_frame(stru
forward:
switch (p->state) {
diff --git a/target/linux/generic/pending-4.9/201-extra_optimization.patch b/target/linux/generic/pending-4.9/201-extra_optimization.patch
index 7b6397919e..3d0fc822bb 100644
--- a/target/linux/generic/pending-4.9/201-extra_optimization.patch
+++ b/target/linux/generic/pending-4.9/201-extra_optimization.patch
@@ -14,12 +14,12 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
--- a/Makefile
+++ b/Makefile
-@@ -656,12 +656,12 @@ endif
+@@ -655,12 +655,12 @@ KBUILD_CFLAGS += $(call cc-option,-fdata
+ endif
ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
- KBUILD_CFLAGS += $(call cc-option,-Oz,-Os)
--KBUILD_CFLAGS += $(call cc-disable-warning,maybe-uninitialized,)
-+KBUILD_CFLAGS += $(call cc-disable-warning,maybe-uninitialized,) $(EXTRA_OPTIMIZATION)
+-KBUILD_CFLAGS += -Os $(call cc-disable-warning,maybe-uninitialized,)
++KBUILD_CFLAGS += -Os $(call cc-disable-warning,maybe-uninitialized,) $(EXTRA_OPTIMIZATION)
else
ifdef CONFIG_PROFILE_ALL_BRANCHES
-KBUILD_CFLAGS += -O2 $(call cc-disable-warning,maybe-uninitialized,)