aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/pending-5.15/435-mtd-add-routerbootpart-parser-config.patch
diff options
context:
space:
mode:
authorAnsuel Smith <ansuelsmth@gmail.com>2021-11-05 00:48:27 +0100
committerDaniel Golle <daniel@makrotopia.org>2022-03-27 00:07:34 +0000
commit483503603cb210919088294051e6d27de1f03718 (patch)
treedca6df4d449c46344976d6bea10435678ac61b75 /target/linux/generic/pending-5.15/435-mtd-add-routerbootpart-parser-config.patch
parent1f302afd7350f46ec0fcc4b12b0ad59ac92fe5b6 (diff)
downloadupstream-483503603cb210919088294051e6d27de1f03718.tar.gz
upstream-483503603cb210919088294051e6d27de1f03718.tar.bz2
upstream-483503603cb210919088294051e6d27de1f03718.zip
generic: 5.15: rework pending patch
Rework pending patch for kernel 5.15 Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
Diffstat (limited to 'target/linux/generic/pending-5.15/435-mtd-add-routerbootpart-parser-config.patch')
-rw-r--r--target/linux/generic/pending-5.15/435-mtd-add-routerbootpart-parser-config.patch8
1 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/generic/pending-5.15/435-mtd-add-routerbootpart-parser-config.patch b/target/linux/generic/pending-5.15/435-mtd-add-routerbootpart-parser-config.patch
index ab1e09a5f1..b258256db6 100644
--- a/target/linux/generic/pending-5.15/435-mtd-add-routerbootpart-parser-config.patch
+++ b/target/linux/generic/pending-5.15/435-mtd-add-routerbootpart-parser-config.patch
@@ -17,9 +17,9 @@ Signed-off-by: Thibaut VARÈNE <hacks@slashdirt.org>
--- a/drivers/mtd/parsers/Kconfig
+++ b/drivers/mtd/parsers/Kconfig
@@ -195,3 +195,12 @@ config MTD_REDBOOT_PARTS_READONLY
- 'FIS directory' images, enable this option.
-
- endif # MTD_REDBOOT_PARTS
+ help
+ This provides support for parsing partitions from Shared Memory (SMEM)
+ for NAND and SPI flash on Qualcomm platforms.
+
+config MTD_ROUTERBOOT_PARTS
+ tristate "RouterBoot flash partition parser"
@@ -32,7 +32,7 @@ Signed-off-by: Thibaut VARÈNE <hacks@slashdirt.org>
--- a/drivers/mtd/parsers/Makefile
+++ b/drivers/mtd/parsers/Makefile
@@ -13,3 +13,4 @@ obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
- obj-$(CONFIG_MTD_PARSER_TRX) += parser_trx.o
obj-$(CONFIG_MTD_SHARPSL_PARTS) += sharpslpart.o
obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
+ obj-$(CONFIG_MTD_QCOMSMEM_PARTS) += qcomsmempart.o
+obj-$(CONFIG_MTD_ROUTERBOOT_PARTS) += routerbootpart.o