aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/pending-5.15/240-remove-unsane-filenames-from-deps_initramfs-list.patch
diff options
context:
space:
mode:
authorAnsuel Smith <ansuelsmth@gmail.com>2021-11-04 21:52:43 +0100
committerDaniel Golle <daniel@makrotopia.org>2022-03-27 00:07:34 +0000
commit9a038e7fd12eae3695875232962f96af8252f3ba (patch)
tree3ac43d08d68ead1856e271791f5f5ba75f555e95 /target/linux/generic/pending-5.15/240-remove-unsane-filenames-from-deps_initramfs-list.patch
parent13960fb0e0babcd99530fcb234073af0c0a5e2f5 (diff)
downloadupstream-9a038e7fd12eae3695875232962f96af8252f3ba.tar.gz
upstream-9a038e7fd12eae3695875232962f96af8252f3ba.tar.bz2
upstream-9a038e7fd12eae3695875232962f96af8252f3ba.zip
generic: 5.15: copy config and patch from 5.10
Copy config and patches from kernel 5.10 to kernel 5.15 Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
Diffstat (limited to 'target/linux/generic/pending-5.15/240-remove-unsane-filenames-from-deps_initramfs-list.patch')
-rw-r--r--target/linux/generic/pending-5.15/240-remove-unsane-filenames-from-deps_initramfs-list.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/target/linux/generic/pending-5.15/240-remove-unsane-filenames-from-deps_initramfs-list.patch b/target/linux/generic/pending-5.15/240-remove-unsane-filenames-from-deps_initramfs-list.patch
new file mode 100644
index 0000000000..29cfade716
--- /dev/null
+++ b/target/linux/generic/pending-5.15/240-remove-unsane-filenames-from-deps_initramfs-list.patch
@@ -0,0 +1,30 @@
+From: Gabor Juhos <juhosg@openwrt.org>
+Subject: usr: sanitize deps_initramfs list
+
+If any filename in the intramfs dependency
+list contains a colon, that causes a kernel
+build error like this:
+
+/devel/openwrt/build_dir/linux-ar71xx_generic/linux-3.6.6/usr/Makefile:58: *** multiple target patterns. Stop.
+make[5]: *** [usr] Error 2
+
+Fix it by removing such filenames from the
+deps_initramfs list.
+
+Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
+Signed-off-by: Felix Fietkau <nbd@nbd.name>
+---
+ usr/Makefile | 8 +++++---
+ 1 file changed, 5 insertions(+), 3 deletions(-)
+
+--- a/usr/Makefile
++++ b/usr/Makefile
+@@ -61,6 +61,8 @@ hostprogs := gen_init_cpio
+ # The dependency list is generated by gen_initramfs.sh -l
+ -include $(obj)/.initramfs_data.cpio.d
+
++deps_initramfs := $(foreach v,$(deps_initramfs),$(if $(findstring :,$(v)),,$(v)))
++
+ # do not try to update files included in initramfs
+ $(deps_initramfs): ;
+